summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openjdk-bin/2135
-rw-r--r--dev-java/openjdk-bin/Manifest1
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.12_p7.ebuild3
3 files changed, 138 insertions, 1 deletions
diff --git a/dev-java/openjdk-bin/2 b/dev-java/openjdk-bin/2
new file mode 100644
index 000000000000..e12c387ddb3d
--- /dev/null
+++ b/dev-java/openjdk-bin/2
@@ -0,0 +1,135 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2 toolchain-funcs
+
+abi_uri() {
+ local os=linux
+ case ${2} in
+ *-macos) os=mac ;;
+ *-solaris) os=solaris ;;
+ esac
+ echo "${2-$1}? (
+ https://github.com/adoptium/temurin${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}U-jdk_${1}_${os}_hotspot_${MY_PV//+/_}.tar.gz
+ )"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+ $(abi_uri aarch64 arm64)
+ $(abi_uri ppc64le ppc64)
+ $(abi_uri x64 amd64)
+ $(abi_uri x64 x64-macos)
+"
+
+DESCRIPTION="Prebuilt Java JDK binaries provided by Eclipse Temurin"
+HOMEPAGE="https://adoptium.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x64-macos"
+IUSE="alsa cups +gentoo-vm headless-awt selinux source"
+
+RDEPEND="
+ >=sys-apps/baselayout-java-0.1.0-r1
+ kernel_linux? (
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz
+ >=sys-libs/glibc-2.2.5:*
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )
+ )"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${MY_PV}"
+
+pkg_pretend() {
+ if [[ "$(tc-is-softfloat)" != "no" ]]; then
+ die "These binaries require a hardfloat system."
+ fi
+}
+
+src_unpack() {
+ default
+ if [[ ${A} == *_mac_* ]] ; then
+ mv -v "${S}/Contents/Home/"* "${S}" || die
+ rm -Rf "${S}/Contents" # drop macOS executable
+ fi
+}
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED%/}/${dest#/}"
+
+ # on macOS if they would exist they would be called .dylib, but most
+ # importantly, there are no different providers, so everything
+ # that's shipped works.
+ if [[ ${A} != *_mac_* ]] ; then
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # prefer system copy # https://bugs.gentoo.org/776676
+ rm -vf lib/libharfbuzz.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
+ fi
+
+ if ! use source ; then
+ rm -v lib/src.zip || die
+ fi
+
+ rm -v lib/security/cacerts || die
+ dosym ../../../../etc/ssl/certs/java/cacerts \
+ "${dest}"/lib/security/cacerts
+
+ dodir "${dest}"
+ cp -pPR * "${ddest}" || die
+
+ # provide stable symlink
+ dosym "${P}" "/opt/${PN}-${SLOT}"
+
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ java-vm_set-pax-markings "${ddest}"
+ java-vm_revdep-mask
+ java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+
+ if use gentoo-vm ; then
+ ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
+ ewarn "recognised by the system. This will almost certainly break"
+ ewarn "many java ebuilds as they are not ready for openjdk-11"
+ else
+ ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
+ ewarn "will not be recognised by the system. For example, simply calling"
+ ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+ ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
+ ewarn "absolute location under ${EPREFIX}/opt/${P}."
+ fi
+}
diff --git a/dev-java/openjdk-bin/Manifest b/dev-java/openjdk-bin/Manifest
index 33acdb53592e..4b8e129c5b0b 100644
--- a/dev-java/openjdk-bin/Manifest
+++ b/dev-java/openjdk-bin/Manifest
@@ -1,6 +1,7 @@
DIST OpenJDK11U-jdk_aarch64_linux_hotspot_11.0.11_9.tar.gz 189549576 BLAKE2B 9eb55593643911573dbb7aa0f69169cf63c0cd8d0a4b4d3a4bf42131f2dfa51305c55c26e802f07fddd70911dba20c4d7b57983782aa2da61fa730f12258a94c SHA512 f2aa4514bad0a4116d0b703adef866f420b1bf264781b58d4075c54747856a657ec7fd1ef622712419823f76a87b9965426f59e5c66b21dbc073387e66f949a9
DIST OpenJDK11U-jdk_aarch64_linux_hotspot_11.0.12_7.tar.gz 189702606 BLAKE2B 110b03fdc85f9456b253569caa6f6be119045cbecb8e13cd1ecc1566236a9ad860dddad9d46ba88c46396a16f27f080364909bf1587f5bdc96e72c9d0ba0b165 SHA512 c6122bae7269143638e43191505e9ea2265280d039de89b7bc2a79aa89eaa3a1658765d8490c4e363e7e7982575bd309f7e6ac18c4fc7bb915dca2b27e7a6a3f
DIST OpenJDK11U-jdk_arm_linux_hotspot_11.0.11_9.tar.gz 180784025 BLAKE2B c15ae126f1c2bb00f97571d4bb3316ecf5ee36a18895eefb48db616996dcdf363acbbd8ac17ecb6a507cc0f3a811f476cd72993b42e0a0b857b82c3e2d4d5279 SHA512 33cdc99dcf119a3f5161cdc08853ed1b8a1630f884577b6a167cf79621b0fa6f87ec652452fce0e27ee550b63952fcf75a3a6bd70c61564faafc0e8e1c74c0bf
+DIST OpenJDK11U-jdk_arm_linux_hotspot_11.0.12_7.tar.gz 180761575 BLAKE2B a04e91561aaa6c3e921c61b8956e797c0de20eea98b1356267a3046db9917df65fcec4c569134675e3adaef259572772deb62c0cbe3e70aef01e7984233f78af SHA512 b0ebe7832c5b03930ee72d2f5ff5171dd44cf0fa1c48120fcb508f1be08921e8ce848f4348f0424eaa9955e1be4b04a9d82ebb72e5bc6a2cf8551fa35da093c7
DIST OpenJDK11U-jdk_ppc64le_linux_hotspot_11.0.11_9.tar.gz 174865783 BLAKE2B 717168b8b2dc326495dc41f3af2d85b515c10774ae58f35bcdf86694d89b1e11db50be24f4c046add5223e912448d67c2ecac8a3a6f3ca2dca3e915fa61f9654 SHA512 dafd40c133fd83c06a29816f4e45ff63e588ea5e6046fe331acbee4eb5efac4b3fc7da0f0fd55e4044846a053644a71efa00e45cf4ba39106b8d1018f9bca0ec
DIST OpenJDK11U-jdk_ppc64le_linux_hotspot_11.0.12_7.tar.gz 175004135 BLAKE2B 36b63c4b8c654c418c244c06d2b2d0d6395ec462c98c3b8548ad15d9f7620b685074307f80c79a0d42e353158d91a2a2c9c2dd6a2d4cca889d2158c2f0736f6a SHA512 34c6c6a309205bb02e52565dbcdb3d7a1f7eff9b7c2212f3a45b519a5032491b8d2c55811b097a6a4a744d4ace38d93ca89c463be9f058008786b1ba0b20cae8
DIST OpenJDK11U-jdk_x64_linux_hotspot_11.0.11_9.tar.gz 192792051 BLAKE2B b11a0934d358d255df743e241fa5040bbc48746b5fd131e98a9b253add114d3504a0f4b10887d9b86189da4f2bccfc65134247b0580d96e2fa7ae9374d44ff38 SHA512 b79eb8a672706b643773711a59a756de88eadd54e74bfef7dad14a0f7ab7412ee6c457b4d3489f6c530abbd442307a9355b5d4a01d2610f90cfd614b614f6507
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.12_p7.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.12_p7.ebuild
index c5bca3458c4f..85c12bd7c71a 100644
--- a/dev-java/openjdk-bin/openjdk-bin-11.0.12_p7.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.12_p7.ebuild
@@ -20,6 +20,7 @@ MY_PV=${PV/_p/+}
SLOT=${MY_PV%%[.+]*}
SRC_URI="
+ $(abi_uri arm)
$(abi_uri aarch64 arm64)
$(abi_uri ppc64le ppc64)
$(abi_uri x64 amd64)
@@ -29,7 +30,7 @@ SRC_URI="
DESCRIPTION="Prebuilt Java JDK binaries provided by Eclipse Temurin"
HOMEPAGE="https://adoptium.net"
LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x64-macos"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x64-macos"
IUSE="alsa cups +gentoo-vm headless-awt selinux source"
RDEPEND="