summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/elixir')
-rw-r--r--dev-lang/elixir/Manifest6
-rw-r--r--dev-lang/elixir/elixir-1.14.5-r2.ebuild (renamed from dev-lang/elixir/elixir-1.11.3.ebuild)13
-rw-r--r--dev-lang/elixir/elixir-1.15.7.ebuild (renamed from dev-lang/elixir/elixir-1.10.4.ebuild)10
-rw-r--r--dev-lang/elixir/elixir-1.16.2.ebuild (renamed from dev-lang/elixir/elixir-1.11.2.ebuild)12
-rw-r--r--dev-lang/elixir/files/elixir-1.11.2-mksh.patch81
-rw-r--r--dev-lang/elixir/files/elixir-1.14.1-make44-parallel-build.patch27
-rw-r--r--dev-lang/elixir/files/elixir-1.14.5-otp26-tests.patch107
-rw-r--r--dev-lang/elixir/files/elixir-1.16.1-skip-tests-requiring-erlang-docs.patch90
-rw-r--r--dev-lang/elixir/metadata.xml18
9 files changed, 254 insertions, 110 deletions
diff --git a/dev-lang/elixir/Manifest b/dev-lang/elixir/Manifest
index 9f9de7f05df4..8171ea81074e 100644
--- a/dev-lang/elixir/Manifest
+++ b/dev-lang/elixir/Manifest
@@ -1,3 +1,3 @@
-DIST elixir-1.10.4.tar.gz 2331003 BLAKE2B 8cb54bcb16762ae345ad9d36a25c28696fd5bb57cf97c5037c21458671e001cfe51a722287243c6a70fe3cea65c9c219e759c8312fc168e93974ac5f0870b47a SHA512 844e405cf344539a9d32dc7f1ead0dc1dfb0d70a9ab718269f4e25e5262f611f96346f5be93cf8e34a75c58c6aabb12e8a796c5cb182955922510c270ef169e7
-DIST elixir-1.11.2.tar.gz 2391833 BLAKE2B 1c11e96830c8719e05e5bc832d4e1d9ca5bb8036803360568fbf4a06a11bb8eb4656aaf1e57a7e04669ddc240d1c04c6a15475e98fcf613ea8bf52b15723fe7f SHA512 472a531353d5f393b0223008ac95ae67b0dc6708143df59a4dd359fdb631329f8a8bded886f53be232e076d194e14a76325fab51a59ec2451706f4f35836bc70
-DIST elixir-1.11.3.tar.gz 2394406 BLAKE2B 066e11651265d63c713809f1968b7dc7faf70e8254ef0aec1978a3db0f92da6bb894e882a1a6c1ba8da13d234c91dc84d2d750b0e044e4cd8706986ec7b2f382 SHA512 4962bb9fcf5f4190a8da22a3e42df5b4e521d73771f6a067edb482b911b0f9fbd2883841d06d94ae4ad6b1db2f61f691e5de4c118c722a16f95830c67ce3e45b
+DIST elixir-1.14.5.tar.gz 3076366 BLAKE2B cf1487c269b4f09c5a7771339782ddc5f6dc2d5f31bd098486824e1f50040462a55a6135e76a7d635461b8d61ce8ab45be2d1da86d60ecf0bc3c86c98b86531d SHA512 589482fb080eb9f71319b7927312ee255dab0376a8fb781533bc97b6a75dd71ec43cd022bb2eff12eca205cdeaf9a6d629f754c555c17cd6222e05912ff3d960
+DIST elixir-1.15.7.tar.gz 3151775 BLAKE2B 62dc5e390f7b704fdab2be91b36faabc62aed097ec1a077476fee0e50717cfe527322d8eaf2afd90035bf1b4fb48803112ef4c7fded20f133b64cea3bee43c6d SHA512 a46f0569cbff342f15a04776f8d57cf2554867546004adabd9b9dff36c184ec56a78f2df2fc6c0855e65c11277662f694f5e6a8c6e1716cf4e22d8fdd5e1d4ae
+DIST elixir-1.16.2.tar.gz 3357093 BLAKE2B 61ba738542d33e827f7352b7f0a27aa76fc06f037d35c56efd96be1c26e28be90b6f2998cd2cac0090e5da771f6c45ad12d68644e36a214de36c9e26d4ac9686 SHA512 1e90adcd5d0512d4b394276e431f3987fc61a3f6191cd5c1d0f7fdd82baba99747aa553a3583e0813ffb5a48a32ce02a24e27b641f86a61e421722a802a850c1
diff --git a/dev-lang/elixir/elixir-1.11.3.ebuild b/dev-lang/elixir/elixir-1.14.5-r2.ebuild
index 4c9e14b12b16..77baef256235 100644
--- a/dev-lang/elixir/elixir-1.11.3.ebuild
+++ b/dev-lang/elixir/elixir-1.14.5-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Elixir programming language"
HOMEPAGE="https://elixir-lang.org"
@@ -9,13 +9,15 @@ SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="Apache-2.0 ErlPL-1.1"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~riscv ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
+# https://hexdocs.pm/elixir/compatibility-and-deprecations.html#compatibility-between-elixir-and-erlang-otp
DEPEND="
- >=dev-lang/erlang-21:0=[ssl]
+ >=dev-lang/erlang-23:0=[ssl]
+ <dev-lang/erlang-27
"
# 'mix' tool collides with sci-biology/phylip, bug #537514
RDEPEND="${DEPEND}
@@ -29,7 +31,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
"${FILESDIR}"/${PN}-1.10.3-no-Q.patch
"${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
- "${FILESDIR}"/${PN}-1.11.2-mksh.patch
+ "${FILESDIR}"/${PN}-1.14.1-make44-parallel-build.patch
+ "${FILESDIR}"/${PN}-1.14.5-otp26-tests.patch
)
src_install() {
diff --git a/dev-lang/elixir/elixir-1.10.4.ebuild b/dev-lang/elixir/elixir-1.15.7.ebuild
index 5d77e804b6ce..5e2210fd3a54 100644
--- a/dev-lang/elixir/elixir-1.10.4.ebuild
+++ b/dev-lang/elixir/elixir-1.15.7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Elixir programming language"
HOMEPAGE="https://elixir-lang.org"
@@ -9,13 +9,15 @@ SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="Apache-2.0 ErlPL-1.1"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
+# https://hexdocs.pm/elixir/compatibility-and-deprecations.html#compatibility-between-elixir-and-erlang-otp
DEPEND="
- >=dev-lang/erlang-21:0=[ssl]
+ >=dev-lang/erlang-24:0=[ssl]
+ <dev-lang/erlang-27
"
# 'mix' tool collides with sci-biology/phylip, bug #537514
RDEPEND="${DEPEND}
diff --git a/dev-lang/elixir/elixir-1.11.2.ebuild b/dev-lang/elixir/elixir-1.16.2.ebuild
index 00e05b4cf117..caa41ed09e6a 100644
--- a/dev-lang/elixir/elixir-1.11.2.ebuild
+++ b/dev-lang/elixir/elixir-1.16.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Elixir programming language"
HOMEPAGE="https://elixir-lang.org"
@@ -9,13 +9,15 @@ SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="Apache-2.0 ErlPL-1.1"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
+# https://hexdocs.pm/elixir/compatibility-and-deprecations.html#between-elixir-and-erlang-otp
DEPEND="
- >=dev-lang/erlang-21:0=[ssl]
+ >=dev-lang/erlang-24:0=[ssl]
+ <dev-lang/erlang-27
"
# 'mix' tool collides with sci-biology/phylip, bug #537514
RDEPEND="${DEPEND}
@@ -29,7 +31,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
"${FILESDIR}"/${PN}-1.10.3-no-Q.patch
"${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
- "${FILESDIR}"/${PN}-1.11.2-mksh.patch
+ "${FILESDIR}"/${PN}-1.16.1-skip-tests-requiring-erlang-docs.patch
)
src_install() {
diff --git a/dev-lang/elixir/files/elixir-1.11.2-mksh.patch b/dev-lang/elixir/files/elixir-1.11.2-mksh.patch
deleted file mode 100644
index 3fda43156890..000000000000
--- a/dev-lang/elixir/files/elixir-1.11.2-mksh.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 69bb81635a77afb28419103bdb02867b48994d4a Mon Sep 17 00:00:00 2001
-From: "Haelwenn (lanodan) Monnier" <contact@hacktivis.me>
-Date: Wed, 9 Dec 2020 18:21:34 +0100
-Subject: [PATCH] bin/elixir: Rename erl() function to erl_set()
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-It conflicted with the erl executable for Korn-derived shells where a function
-can be used in `exec command`.
-
-It isn't clear which behavior is expected from reading the POSIX specification
-but "Shell Command Language § 2.9.1 Simple Commands" clears the usage of
-the term `command` quite well.
-And even with excluding functions from the `command` operand of `exec`,
-why are aliases accepted? (in most if not all shells)
-
-See: https://bugs.gentoo.org/729964
----
- bin/elixir | 28 ++++++++++++++--------------
- 1 file changed, 14 insertions(+), 14 deletions(-)
-
---- a/bin/elixir
-+++ b/bin/elixir
-@@ -70,7 +70,7 @@ readlink_f () {
- ERL=""
-
- # Stores erl arguments preserving spaces/quotes (mimics an array)
--erl () {
-+erl_set () {
- eval "E${E}=\$1"
- E=$((E + 1))
- }
-@@ -137,34 +137,34 @@ while [ $I -le $LENGTH ]; do
- ;;
- --cookie)
- S=2
-- erl "-setcookie"
-- erl "$2"
-+ erl_set "-setcookie"
-+ erl_set "$2"
- ;;
- --sname|--name)
- S=2
-- erl "$(echo "$1" | cut -c 2-)"
-- erl "$2"
-+ erl_set "$(echo "$1" | cut -c 2-)"
-+ erl_set "$2"
- ;;
- --erl-config)
- S=2
-- erl "-config"
-- erl "$2"
-+ erl_set "-config"
-+ erl_set "$2"
- ;;
- --vm-args)
- S=2
-- erl "-args_file"
-- erl "$2"
-+ erl_set "-args_file"
-+ erl_set "$2"
- ;;
- --boot)
- S=2
-- erl "-boot"
-- erl "$2"
-+ erl_set "-boot"
-+ erl_set "$2"
- ;;
- --boot-var)
- S=3
-- erl "-boot_var"
-- erl "$2"
-- erl "$3"
-+ erl_set "-boot_var"
-+ erl_set "$2"
-+ erl_set "$3"
- ;;
- --pipe-to)
- S=3
diff --git a/dev-lang/elixir/files/elixir-1.14.1-make44-parallel-build.patch b/dev-lang/elixir/files/elixir-1.14.1-make44-parallel-build.patch
new file mode 100644
index 000000000000..81d40f751da8
--- /dev/null
+++ b/dev-lang/elixir/files/elixir-1.14.1-make44-parallel-build.patch
@@ -0,0 +1,27 @@
+From c668ce22b0dd72261621f19f124490eb5425eacd Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Tue, 15 Nov 2022 21:38:50 +0000
+Subject: [PATCH] Disable parallel build in Make 4.4
+
+In versions of GNU Make prior to 4.4, ".NOTPARALLEL: compile" made the whole
+build run serially. In 4.4 and later, ".NOTPARALLEL: compile" makes only
+the compile target run serially.
+
+This breaks the build and can lead to e.g. EEx being built before Mix.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f6ba18d90e..8bb5bcdc65 100644
+--- a/Makefile
++++ b/Makefile
+@@ -24,7 +24,7 @@ SOURCE_DATE_EPOCH_PATH = lib/elixir/tmp/ebin_reproducible
+ SOURCE_DATE_EPOCH_FILE = $(SOURCE_DATE_EPOCH_PATH)/SOURCE_DATE_EPOCH
+
+ .PHONY: install compile erlang elixir unicode app build_plt clean_plt dialyze test check_reproducible clean clean_residual_files format install_man clean_man docs Docs.zip Precompiled.zip zips
+-.NOTPARALLEL: compile
++.NOTPARALLEL:
+
+ #==> Functions
+
diff --git a/dev-lang/elixir/files/elixir-1.14.5-otp26-tests.patch b/dev-lang/elixir/files/elixir-1.14.5-otp26-tests.patch
new file mode 100644
index 000000000000..4e554cda252a
--- /dev/null
+++ b/dev-lang/elixir/files/elixir-1.14.5-otp26-tests.patch
@@ -0,0 +1,107 @@
+Grabbed as-is from https://github.com/elixir-lang/elixir/commit/54516c5684daa3af7f15477c77fae39e8d0c6482 which was done for 1.15.x
+
+From 54516c5684daa3af7f15477c77fae39e8d0c6482 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Valim?= <jose.valim@dashbit.co>
+Date: Sun, 1 Oct 2023 15:46:17 +0200
+Subject: [PATCH] Address tests on Erlang/OTP 26.1, closes #12975
+
+---
+ lib/ex_unit/lib/ex_unit/callbacks.ex | 9 +-----
+ lib/ex_unit/test/ex_unit/formatter_test.exs | 31 +++++++++-----------
+ lib/ex_unit/test/ex_unit/supervised_test.exs | 11 ++-----
+ 3 files changed, 18 insertions(+), 33 deletions(-)
+
+diff --git a/lib/ex_unit/lib/ex_unit/callbacks.ex b/lib/ex_unit/lib/ex_unit/callbacks.ex
+index 060d207516a..2dbe9bd0e4a 100644
+--- a/lib/ex_unit/lib/ex_unit/callbacks.ex
++++ b/lib/ex_unit/lib/ex_unit/callbacks.ex
+@@ -549,14 +549,7 @@ defmodule ExUnit.Callbacks do
+ end
+
+ child_spec = Supervisor.child_spec(child_spec_or_module, opts)
+-
+- case Supervisor.start_child(sup, child_spec) do
+- {:error, {:already_started, _pid}} ->
+- {:error, {:duplicate_child_name, child_spec.id}}
+-
+- other ->
+- other
+- end
++ Supervisor.start_child(sup, child_spec)
+ end
+
+ @doc """
+diff --git a/lib/ex_unit/test/ex_unit/formatter_test.exs b/lib/ex_unit/test/ex_unit/formatter_test.exs
+index afb66a52436..bb9642fbcc4 100644
+--- a/lib/ex_unit/test/ex_unit/formatter_test.exs
++++ b/lib/ex_unit/test/ex_unit/formatter_test.exs
+@@ -491,28 +491,25 @@ defmodule ExUnit.FormatterTest do
+ test "inspect failure" do
+ failure = [{:error, catch_assertion(assert :will_fail == %BadInspect{}), []}]
+
+- message = ~S'''
+- got FunctionClauseError with message:
+-
+- """
+- no function clause matching in Inspect.ExUnit.FormatterTest.BadInspect.inspect/2
+- """
+-
+- while inspecting:
+-
+- %{__struct__: ExUnit.FormatterTest.BadInspect, key: 0}
+-
+- Stacktrace:
+- '''
+-
+- assert format_test_failure(test(), failure, 1, 80, &formatter/2) =~ """
++ assert format_test_failure(test(), failure, 1, 80, &formatter/2) =~ ~s'''
+ 1) world (Hello)
+ test/ex_unit/formatter_test.exs:1
+ Assertion with == failed
+ code: assert :will_fail == %BadInspect{}
+ left: :will_fail
+- right: #Inspect.Error<\n#{message}\
+- """
++ right: #Inspect.Error<
++ got FunctionClauseError with message:
++
++ """
++ no function clause matching in Inspect.ExUnit.FormatterTest.BadInspect.inspect/2
++ """
++
++ while inspecting:
++
++ #{inspect(%BadInspect{}, structs: false)}
++
++ Stacktrace:
++ '''
+ end
+
+ defmodule BadMessage do
+diff --git a/lib/ex_unit/test/ex_unit/supervised_test.exs b/lib/ex_unit/test/ex_unit/supervised_test.exs
+index 577ae6b9676..a02dfe3c0c5 100644
+--- a/lib/ex_unit/test/ex_unit/supervised_test.exs
++++ b/lib/ex_unit/test/ex_unit/supervised_test.exs
+@@ -73,19 +73,14 @@ defmodule ExUnit.SupervisedTest do
+
+ test "starts a supervised process with ID checks" do
+ {:ok, pid} = start_supervised({MyAgent, 0})
++ assert is_pid(pid)
+
+- assert {:error, {:duplicate_child_name, ExUnit.SupervisedTest.MyAgent}} =
+- start_supervised({MyAgent, 0})
+-
+- assert {:error, {{:already_started, ^pid}, _}} = start_supervised({MyAgent, 0}, id: :another)
++ assert {:error, _} = start_supervised({MyAgent, 0})
++ assert {:error, _} = start_supervised({MyAgent, 0}, id: :another)
+
+ assert_raise RuntimeError, ~r"Reason: bad child specification", fn ->
+ start_supervised!(%{id: 1, start: :oops})
+ end
+-
+- assert_raise RuntimeError, ~r"Reason: already started", fn ->
+- start_supervised!({MyAgent, 0}, id: :another)
+- end
+ end
+
+ test "stops a supervised process" do
diff --git a/dev-lang/elixir/files/elixir-1.16.1-skip-tests-requiring-erlang-docs.patch b/dev-lang/elixir/files/elixir-1.16.1-skip-tests-requiring-erlang-docs.patch
new file mode 100644
index 000000000000..187c45a7d902
--- /dev/null
+++ b/dev-lang/elixir/files/elixir-1.16.1-skip-tests-requiring-erlang-docs.patch
@@ -0,0 +1,90 @@
+Upstream-Commit: https://github.com/elixir-lang/elixir/commit/c50863615c0e8ac957e22ae01a6f9af23978c3f9
+
+From c50863615c0e8ac957e22ae01a6f9af23978c3f9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Valim?= <jose.valim@dashbit.co>
+Date: Thu, 8 Feb 2024 08:08:03 +0100
+Subject: [PATCH] Skip tests if Erlang was compiled without docs, closes #13322
+
+---
+ lib/iex/test/iex/helpers_test.exs | 12 +++++++++---
+ lib/iex/test/test_helper.exs | 10 +++++++++-
+ 2 files changed, 18 insertions(+), 4 deletions(-)
+
+diff --git a/lib/iex/test/iex/helpers_test.exs b/lib/iex/test/iex/helpers_test.exs
+index 54f946516ce..171acc72abc 100644
+--- a/lib/iex/test/iex/helpers_test.exs
++++ b/lib/iex/test/iex/helpers_test.exs
+@@ -332,17 +332,20 @@ defmodule IEx.HelpersTest do
+ assert help =~ "Welcome to Interactive Elixir"
+ end
+
++ @tag :erlang_doc
+ test "prints Erlang module documentation" do
+ captured = capture_io(fn -> h(:timer) end)
+ assert captured =~ "This module provides useful functions related to time."
+ end
+
++ @tag :erlang_doc
+ test "prints Erlang module function specs" do
+ captured = capture_io(fn -> h(:timer.sleep() / 1) end)
+ assert captured =~ ":timer.sleep/1"
+ assert captured =~ "-spec sleep(Time) -> ok when Time :: timeout()."
+ end
+
++ @tag :erlang_doc
+ test "handles non-existing Erlang module function" do
+ captured = capture_io(fn -> h(:timer.baz() / 1) end)
+ assert captured =~ "No documentation for :timer.baz was found"
+@@ -1008,13 +1011,15 @@ defmodule IEx.HelpersTest do
+ cleanup_modules([TypeSample])
+ end
+
+- test "prints all types in erlang module" do
++ @tag :erlang_doc
++ test "prints all types in Erlang module" do
+ captured = capture_io(fn -> t(:queue) end)
+ assert captured =~ "-type queue() :: queue(_)"
+ assert captured =~ "-opaque queue(Item)"
+ end
+
+- test "prints single type from erlang module" do
++ @tag :erlang_doc
++ test "prints single type from Erlang module" do
+ captured = capture_io(fn -> t(:erlang.iovec()) end)
+ assert captured =~ "-type iovec() :: [binary()]"
+ assert captured =~ "A list of binaries."
+@@ -1024,7 +1029,8 @@ defmodule IEx.HelpersTest do
+ assert captured =~ "A list of binaries."
+ end
+
+- test "handles non-existing types from erlang module" do
++ @tag :erlang_doc
++ test "handles non-existing types from Erlang module" do
+ captured = capture_io(fn -> t(:erlang.foo()) end)
+ assert captured =~ "No type information for :erlang.foo was found or :erlang.foo is private"
+
+diff --git a/lib/iex/test/test_helper.exs b/lib/iex/test/test_helper.exs
+index f5a55f0aa80..b32c8be4e91 100644
+--- a/lib/iex/test/test_helper.exs
++++ b/lib/iex/test/test_helper.exs
+@@ -7,11 +7,19 @@ IEx.configure(colors: [enabled: false])
+ {line_exclude, line_include} =
+ if line = System.get_env("LINE"), do: {[:test], [line: line]}, else: {[], []}
+
++erlang_doc_exclude =
++ if match?({:docs_v1, _, _, _, _, _, _}, Code.fetch_docs(:array)) do
++ []
++ else
++ IO.puts("Erlang/OTP compiled without docs, some tests are excluded...")
++ [:erlang_doc]
++ end
++
+ ExUnit.start(
+ assert_receive_timeout: assert_timeout,
+ trace: !!System.get_env("TRACE"),
+ include: line_include,
+- exclude: line_exclude
++ exclude: line_exclude ++ erlang_doc_exclude
+ )
+
+ defmodule IEx.Case do
diff --git a/dev-lang/elixir/metadata.xml b/dev-lang/elixir/metadata.xml
index fbe86b3bebe7..10b86bcffd2c 100644
--- a/dev-lang/elixir/metadata.xml
+++ b/dev-lang/elixir/metadata.xml
@@ -1,18 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>styx.mp@gmail.com</email>
- <name>Mikhail</name>
+ <maintainer type="person" proxied="yes">
+ <email>contact@hacktivis.me</email>
+ <name>Haelwenn (lanodan) Monnier</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
- <maintainer type="person">
- <email>slyfox@gentoo.org</email>
- <name>Sergei Trofimovich</name>
- </maintainer>
<upstream>
<bugs-to>
https://github.com/elixir-lang/elixir/issues
@@ -23,8 +19,6 @@
<doc lang="en">
http://elixir-lang.org/docs.html
</doc>
- <remote-id type="github">
- elixir-lang/elixir
- </remote-id>
+ <remote-id type="github">elixir-lang/elixir</remote-id>
</upstream>
</pkgmetadata>