summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc/ghc-7.4.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-7.4.2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/ghc/ghc-7.4.2.ebuild b/dev-lang/ghc/ghc-7.4.2.ebuild
index 679f1ba9eaeb..366f1d473b1a 100644
--- a/dev-lang/ghc/ghc-7.4.2.ebuild
+++ b/dev-lang/ghc/ghc-7.4.2.ebuild
@@ -111,8 +111,6 @@ PDEPEND="
# ia64 fails to return from STG GMP primitives (stage2 always SIGSEGVs)
REQUIRED_USE="ia64? ( !gmp )"
-use binary && QA_PREBUILT="*"
-
append-ghc-cflags() {
local flag compile assemble link
for flag in $*; do
@@ -248,6 +246,9 @@ relocate_ghc() {
}
pkg_setup() {
+ # quiet portage about prebuilt binaries
+ use binary && QA_PREBUILT="*"
+
if use ghcbootstrap; then
ewarn "You requested ghc bootstrapping, this is usually only used"
ewarn "by Gentoo developers to make binary .tbz2 packages for"