summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
index 3502c2c009fd..60a6e2908ead 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -87,6 +87,11 @@ src_prepare() {
ln -s /usr/bin/$CHOST-ld \
"${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/ld \
|| die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ || die
+ ln -s /usr/bin/$CHOST-as \
+ "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ || die
fi
CC=${GCC}