summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/haxe')
-rw-r--r--dev-lang/haxe/Manifest1
-rw-r--r--dev-lang/haxe/haxe-4.2.4.ebuild60
-rw-r--r--dev-lang/haxe/metadata.xml19
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
new file mode 100644
index 000000000000..dacd6fc5c9fe
--- /dev/null
+++ b/dev-lang/haxe/Manifest
@@ -0,0 +1 @@
+DIST haxe-4.2.4.tar.gz 9151011 BLAKE2B 76e4442dbd33669abb2defcb66a781bf013ac41a4853f7911824e16816c60fff7e46bd58b9f2830194326aadbd79b2f07ab14308efdb0ef1e26177178daf3941 SHA512 c447b2fa7e7b7149a87af2dd75e08cce1b8d96238b88024d875659add62fa97d554ecd7f13200b817545eda8be00d61399551d64f7dbc9cc1aa66a5517dd2485
diff --git a/dev-lang/haxe/haxe-4.2.4.ebuild b/dev-lang/haxe/haxe-4.2.4.ebuild
new file mode 100644
index 000000000000..3a305a28ad8b
--- /dev/null
+++ b/dev-lang/haxe/haxe-4.2.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multi-target universal programming language"
+HOMEPAGE="https://haxe.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
+else
+ # Haxe-debian already contains correct git modules
+ SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/haxe-debian-upstream-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-ml/ptmap:=
+ dev-ml/sedlex:=
+ dev-ml/ocaml-sha:=
+ dev-ml/xml-light:=
+
+ dev-lang/neko:=
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ net-libs/mbedtls:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED="usr/bin/haxelib"
+QA_PRESTRIPPED="usr/bin/haxelib"
+
+src_configure() {
+ use ocamlopt && export OCAMLOPT=ocamlopt.opt
+}
+
+src_compile() {
+ local mymakeargs=(
+ BRANCH=""
+ COMMIT_DATE=""
+ COMMIT_SHA=""
+ INSTALL_DIR=/usr
+ )
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_DIR=/usr install
+
+ dodoc *.md
+}
diff --git a/dev-lang/haxe/metadata.xml b/dev-lang/haxe/metadata.xml
new file mode 100644
index 000000000000..d00b93a2d21b
--- /dev/null
+++ b/dev-lang/haxe/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Haxe is an open source toolkit based on a modern, high level, static-typed
+ programming language, a cross-compiler, a complete cross-platform standard
+ library and ways to access each platform's native capabilities.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/HaxeFoundation/haxe</bugs-to>
+ <remote-id type="github">HaxeFoundation/haxe-debian</remote-id>
+ <remote-id type="github">HaxeFoundation/haxe</remote-id>
+ </upstream>
+</pkgmetadata>