summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/haxe')
-rw-r--r--dev-lang/haxe/Manifest1
-rw-r--r--dev-lang/haxe/haxe-4.2.5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
index dacd6fc5c9fe..3991d4f0956b 100644
--- a/dev-lang/haxe/Manifest
+++ b/dev-lang/haxe/Manifest
@@ -1 +1,2 @@
DIST haxe-4.2.4.tar.gz 9151011 BLAKE2B 76e4442dbd33669abb2defcb66a781bf013ac41a4853f7911824e16816c60fff7e46bd58b9f2830194326aadbd79b2f07ab14308efdb0ef1e26177178daf3941 SHA512 c447b2fa7e7b7149a87af2dd75e08cce1b8d96238b88024d875659add62fa97d554ecd7f13200b817545eda8be00d61399551d64f7dbc9cc1aa66a5517dd2485
+DIST haxe-4.2.5.tar.gz 9151978 BLAKE2B da6555707e0c0c34fc9a7c987bf2258e08557acb4629422d9f50ac4c025675601ccb25cea322dad0c16a4378dc48cac8e6e6acf1b94965a7eac5261c765d4ccb SHA512 a371245f5f7c18c2d16a9c7246829225d9f03beb796cb76b0dd5011e7a5a56e25f871c8cc7257a6e6b7a855804f6e62d48c2974a9ce3f4e6591d44f06bfa65ca
diff --git a/dev-lang/haxe/haxe-4.2.5.ebuild b/dev-lang/haxe/haxe-4.2.5.ebuild
new file mode 100644
index 000000000000..b4c6b1ae2869
--- /dev/null
+++ b/dev-lang/haxe/haxe-4.2.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multi-target universal programming language"
+HOMEPAGE="https://haxe.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
+else
+ # Haxe-debian already contains correct git modules
+ SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/haxe-debian-upstream-${PV}
+fi
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+# NOTICE:
+# Theoretically luv <= 0.5.8 is pinned but it is because of mingw issues
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-ml/luv:=
+ dev-ml/ocaml-sha:=
+ dev-ml/ptmap:=
+ dev-ml/sedlex:=
+ dev-ml/xml-light:=
+
+ dev-lang/neko:=
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ net-libs/mbedtls:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/camlp5
+ dev-ml/dune
+ dev-ml/findlib
+"
+
+QA_FLAGS_IGNORED="usr/bin/haxelib"
+QA_PRESTRIPPED="usr/bin/haxelib"
+
+src_configure() {
+ if use ocamlopt ; then
+ export OCAMLOPT=ocamlopt.opt
+ else
+ export OCAMLOPT=ocamlopt
+ fi
+}
+
+src_compile() {
+ emake -j1 BRANCH="" COMMIT_DATE="" COMMIT_SHA="" \
+ OCAMLOPT="${OCAMLOPT}" INSTALL_DIR=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_DIR=/usr install
+ dodoc *.md
+}