summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/inform')
-rw-r--r--dev-lang/inform/Manifest1
-rw-r--r--dev-lang/inform/inform-6.33.1_p2.ebuild26
-rw-r--r--dev-lang/inform/inform-6.35_p4.ebuild51
-rw-r--r--dev-lang/inform/metadata.xml52
4 files changed, 79 insertions, 51 deletions
diff --git a/dev-lang/inform/Manifest b/dev-lang/inform/Manifest
index fc608436e98c..affbf7ed9449 100644
--- a/dev-lang/inform/Manifest
+++ b/dev-lang/inform/Manifest
@@ -1 +1,2 @@
DIST inform-6.33.1-b2.tar.gz 1822648 BLAKE2B e2ea59aa310b2f0122d1b834d98b0b827b945a8031a3e61c70bf502f7a746f43b81035cc22805ab351abf6f9df9ba898ea6ea83da863ef9aa313840ed974d725 SHA512 12cc10b7dae4118600a4d19d0aa44c3a7c93dfc8aa17bd56df7b9237f21df0ae99db6840eefaa5b11ff346369c6f6f2f128167b3479c8f540c29e3e36666c368
+DIST inform-6.35-r4.tar.gz 2307089 BLAKE2B 9864324fe29fe920e226a239f92f327678ed796e5f5a27b3814f62b1158673b2c14d6771abd7af6f9743bb0949c4c6de75a6b591337b0e99196f8ab4d9f0c9f7 SHA512 c30c7067786845e0c77783f7a03a151ae1238978f648f6036fe9535a33662c76abc11db21bab00fe60c4742cd4da46e4674081711b9b3852520bfb14c1b068a6
diff --git a/dev-lang/inform/inform-6.33.1_p2.ebuild b/dev-lang/inform/inform-6.33.1_p2.ebuild
index 939c464d7591..f07551c95d98 100644
--- a/dev-lang/inform/inform-6.33.1_p2.ebuild
+++ b/dev-lang/inform/inform-6.33.1_p2.ebuild
@@ -1,25 +1,31 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-MY_P=${P/_p/-b}
-DESCRIPTION="design system for interactive fiction"
-HOMEPAGE="http://www.inform-fiction.org/"
-SRC_URI="http://mirror.ifarchive.org/if-archive/infocom/compilers/inform6/source/${MY_P}.tar.gz"
+EAPI=8
+
+MY_P="${P/_p/-b}"
+
+DESCRIPTION="Design system for interactive fiction"
+HOMEPAGE="https://www.inform-fiction.org/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="Artistic-2 Inform"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="emacs"
-PDEPEND="emacs? ( app-emacs/inform-mode )"
-S=${WORKDIR}/${MY_P}
+PDEPEND="emacs? ( app-emacs/inform-mode )"
src_install() {
default
+
dodoc VERSION
+
docinto tutorial
dodoc tutor/README tutor/*.inf
- mv "${ED}"/usr/share/${PN}/manual "${ED}"/usr/share/doc/${PF}/html
- rmdir "${ED}"/usr/share/inform/{include,module}
+
+ mv "${ED}"/usr/share/{${PN}/manual,doc/${PF}/html} || die
+ rmdir "${ED}"/usr/share/inform/{include,module} || die
+ rm "${ED}"/usr/share/inform/6.33b2/include/SmartCantGo.h || die #723062
}
diff --git a/dev-lang/inform/inform-6.35_p4.ebuild b/dev-lang/inform/inform-6.35_p4.ebuild
new file mode 100644
index 000000000000..56506b5a25f1
--- /dev/null
+++ b/dev-lang/inform/inform-6.35_p4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-r}"
+
+DESCRIPTION="Design system for interactive fiction"
+HOMEPAGE="https://www.inform-fiction.org/"
+SRC_URI="https://ifarchive.org/if-archive/infocom/compilers/inform6/source/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Artistic-2 Inform"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="emacs tools"
+# non-interactive tests use ruby, seem broken, and return true even on failure
+RESTRICT="test"
+
+RDEPEND="
+ tools? (
+ dev-lang/perl
+ dev-perl/DateTime
+ )"
+PDEPEND="emacs? ( app-emacs/inform-mode )"
+
+src_compile() {
+ tc-export CC
+
+ emake PREFIX="${EPREFIX}"/usr OPTS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ local emakeargs=(
+ PREFIX="${ED}"/usr
+ REAL_PREFIX="${EPREFIX}"/usr
+ MANDIR="${ED}"/usr/share/man/man1
+ PUNYDOCS="${ED}"/usr/share/doc/${PF}/punyinform
+ PUNYTESTS="${T}" # don't install tests
+ )
+
+ emake -j1 "${emakeargs[@]}" install
+
+ dodoc AUTHORS NEWS README.md VERSION docs/README*
+
+ use tools || rm "${ED}"/usr/bin/*blorb* || die
+
+ find "${ED}"/usr/share/doc \( -name Makefile -o -name 'custom.*' \) -delete || die
+}
diff --git a/dev-lang/inform/metadata.xml b/dev-lang/inform/metadata.xml
index 42730dae3fb8..20f18c5cfb1b 100644
--- a/dev-lang/inform/metadata.xml
+++ b/dev-lang/inform/metadata.xml
@@ -1,44 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <longdescription>
-A Design System for Interactive Fiction
-
-Just as film might be called a form of literature which needs technology to be
-read (a cinema projector or a television set) and to be written (a camera),
-interactive fiction is read with the aid of a computer. On this analogy, Inform
-is a piece of software enabling any modern computer to be used as the camera, or
-the film studio, to create works of interactive fiction. To read the resulting
-works, you and your audience need only a simpler piece of software called an
-interpreter.
-
-In this genre of fiction, the computer describes a world and the player types
-instructions like touch the mirror for the protagonist character to follow; the
-computer responds by describing the result, and so on until a story is told.
-
-Interactive fiction emerged from the old-style "adventure game" (c.1975) and
-tends to be a playful genre, which must sometimes be teased out as though it were
-a cryptic crossword puzzle. But this doesn't prevent it from being an artistic
-medium, which has attracted (for instance) the former U.S. Poet Laureate, Robert
-Pinsky, and the novelists Thomas M. Disch and Michael Crichton. An interactive
-fiction is not a child's puzzle-book, with a maze on one page and a rebus on the
-next, but nor is it a novel. Neither pure interaction nor pure fiction, it lies
-in a strange and still largely unexplored land in between.
-
-Since its invention (by Graham Nelson in 1993), Inform has been used to design
-some hundreds of works of interactive fiction, in eight languages, reviewed in
-periodicals ranging in specialisation from XYZZYnews to The New York Times. It
-accounts for around ten thousand postings per year to Internet newsgroups.
-Commercially, Inform has been used as a multimedia games prototyping tool.
-Academically, it has turned up in syllabuses and seminars from computer science
-to theoretical architecture, and appears in books such as Cybertext: Perspectives
-on Ergodic Literature (E. J. Aarseth, Johns Hopkins Press, 1997). Having started
-as a revival of the then-disused Infocom adventure game format, the Z-Machine,
-Inform came full circle when it produced Infocom's only text game of the 1990s:
-Zork: The Undiscovered Underground, by Mike Berlyn and Marc Blank.
- </longdescription>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="tools">Install blorbtools for manipulating Blorb files</flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">DavidGriffith/inform6unix</remote-id>
+ </upstream>
</pkgmetadata>