summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files')
-rw-r--r--dev-lang/julia/files/julia-1.1.0-fix_build_system.patch53
-rw-r--r--dev-lang/julia/files/julia-1.1.0-fix_llvm_install.patch15
-rw-r--r--dev-lang/julia/files/julia-1.4.0-no_symlink_llvm.patch10
-rw-r--r--dev-lang/julia/files/julia-1.8.0-llvm-no-bindings.patch11
-rw-r--r--dev-lang/julia/files/julia-1.8.3-gcc13.patch10
-rw-r--r--dev-lang/julia/files/julia-1.9.4-no-doc-install.patch13
-rw-r--r--dev-lang/julia/files/julia-1.9.4-string-replace.patch13
7 files changed, 47 insertions, 78 deletions
diff --git a/dev-lang/julia/files/julia-1.1.0-fix_build_system.patch b/dev-lang/julia/files/julia-1.1.0-fix_build_system.patch
deleted file mode 100644
index 394f5900a90e..000000000000
--- a/dev-lang/julia/files/julia-1.1.0-fix_build_system.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/Make.inc b/Make.inc
-index 81ff923..79e47f1 100644
---- a/Make.inc
-+++ b/Make.inc
-@@ -185,7 +185,7 @@ USE_GPL_LIBS ?= 1
- # Directories where said libraries get installed to
- prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
- bindir := $(prefix)/bin
--libdir := $(prefix)/lib
-+libdir := $(prefix)/GENTOOLIBDIR
- libexecdir := $(prefix)/libexec
- datarootdir := $(prefix)/share
- docdir := $(datarootdir)/doc/julia
-@@ -417,7 +417,7 @@ ifneq ($(OS), WINNT)
- JCXXFLAGS += -pedantic
- endif
- DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -ggdb2 -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECLANG),1)
-@@ -428,7 +428,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS := -fasynchronous-unwind-tables
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g
-+SHIPFLAGS := GENTOOCFLAGS
- ifeq ($(OS), Darwin)
- ifeq ($(USE_LIBCPP), 1)
- MACOSX_VERSION_MIN := 10.8
-@@ -457,7 +457,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
- JCPPFLAGS :=
- JCXXFLAGS := -pipe $(fPIC) -fno-rtti
- DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
--SHIPFLAGS := -O3 -g -falign-functions
-+SHIPFLAGS := GENTOOCFLAGS
- endif
-
- ifeq ($(USECCACHE), 1)
-diff --git a/doc/Makefile b/doc/Makefile
-index 99e60ee..2027fb5 100644
---- a/doc/Makefile
-+++ b/doc/Makefile
-@@ -30,7 +30,7 @@ deps: UnicodeData.txt
- $(JLCHECKSUM) UnicodeData.txt
-
- clean:
-- -rm -rf _build/* deps/* docbuild.log UnicodeData.txt
-+ @echo "Do not clean doc/_build/html. Just use it..."
-
- cleanall: clean
-
diff --git a/dev-lang/julia/files/julia-1.1.0-fix_llvm_install.patch b/dev-lang/julia/files/julia-1.1.0-fix_llvm_install.patch
deleted file mode 100644
index 9cb75188b963..000000000000
--- a/dev-lang/julia/files/julia-1.1.0-fix_llvm_install.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/deps/llvm.mk 2019-02-09 10:09:30.102927517 +0300
-+++ b/deps/llvm.mk 2019-02-09 10:10:51.479924878 +0300
-@@ -464,10 +464,11 @@
-
- $(build_prefix)/manifest/llvm: | $(llvm_python_workaround)
-
-+# unset DESTDIR to fix https://github.com/JuliaLang/julia/issues/23462
- LLVM_INSTALL = \
- cd $1 && mkdir -p $2$$(build_depsbindir) && \
- cp -r $$(LLVM_SRC_DIR)/utils/lit $2$$(build_depsbindir)/ && \
-- $$(CMAKE) -DCMAKE_INSTALL_PREFIX="$2$$(build_prefix)" -P cmake_install.cmake
-+ DESTDIR="" $$(CMAKE) -DCMAKE_INSTALL_PREFIX="$2$$(build_prefix)" -P cmake_install.cmake
- ifeq ($(OS), WINNT)
- LLVM_INSTALL += && cp $2$$(build_shlibdir)/LLVM.dll $2$$(build_depsbindir)
- endif
diff --git a/dev-lang/julia/files/julia-1.4.0-no_symlink_llvm.patch b/dev-lang/julia/files/julia-1.4.0-no_symlink_llvm.patch
deleted file mode 100644
index 1b6371b120d9..000000000000
--- a/dev-lang/julia/files/julia-1.4.0-no_symlink_llvm.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/base/Makefile 2019-11-17 14:07:20.000000000 -0500
-+++ b/base/Makefile 2020-03-28 20:38:40.041571679 -0400
-@@ -223,7 +223,7 @@
- ln -sf "$$REALPATH" "$@"
- ifneq ($(USE_SYSTEM_LLVM),0)
- ifneq ($(USE_LLVM_SHLIB),0)
--SYMLINK_SYSTEM_LIBRARIES += symlink_libLLVM
-+#SYMLINK_SYSTEM_LIBRARIES += symlink_libLLVM
- endif
- endif
diff --git a/dev-lang/julia/files/julia-1.8.0-llvm-no-bindings.patch b/dev-lang/julia/files/julia-1.8.0-llvm-no-bindings.patch
new file mode 100644
index 000000000000..d5511dee0d91
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.8.0-llvm-no-bindings.patch
@@ -0,0 +1,11 @@
+--- a/deps/llvm.mk
++++ b/deps/llvm.mk
+@@ -94,7 +94,7 @@ endif
+ LLVM_CMAKE += -DLLVM_TOOLS_INSTALL_DIR=$(call rel_path,$(build_prefix),$(build_depsbindir))
+ LLVM_CMAKE += -DLLVM_UTILS_INSTALL_DIR=$(call rel_path,$(build_prefix),$(build_depsbindir))
+ LLVM_CMAKE += -DLLVM_INCLUDE_UTILS=ON -DLLVM_INSTALL_UTILS=ON
+-LLVM_CMAKE += -DLLVM_BINDINGS_LIST="" -DLLVM_INCLUDE_DOCS=Off -DLLVM_ENABLE_TERMINFO=Off -DHAVE_HISTEDIT_H=Off -DHAVE_LIBEDIT=Off
++LLVM_CMAKE += -DLLVM_BINDINGS_LIST="" -DLLVM_ENABLE_BINDINGS=OFF -DLLVM_INCLUDE_DOCS=Off -DLLVM_ENABLE_TERMINFO=Off -DHAVE_HISTEDIT_H=Off -DHAVE_LIBEDIT=Off
+ ifeq ($(LLVM_ASSERTIONS), 1)
+ LLVM_CMAKE += -DLLVM_ENABLE_ASSERTIONS:BOOL=ON
+ endif # LLVM_ASSERTIONS
diff --git a/dev-lang/julia/files/julia-1.8.3-gcc13.patch b/dev-lang/julia/files/julia-1.8.3-gcc13.patch
new file mode 100644
index 000000000000..96e2e48ba78d
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.8.3-gcc13.patch
@@ -0,0 +1,10 @@
+--- a/deps/srccache/JuliaLang-llvm-project-8a2ae8c/llvm/include/llvm/Support/Signals.h
++++ b/deps/srccache/JuliaLang-llvm-project-8a2ae8c/llvm/include/llvm/Support/Signals.h
+@@ -15,6 +15,7 @@
+ #define LLVM_SUPPORT_SIGNALS_H
+
+ #include <string>
++#include <cstdint>
+
+ namespace llvm {
+ class StringRef;
diff --git a/dev-lang/julia/files/julia-1.9.4-no-doc-install.patch b/dev-lang/julia/files/julia-1.9.4-no-doc-install.patch
new file mode 100644
index 000000000000..e1976a3fcde1
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.9.4-no-doc-install.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 68e2136..a38edee 100644
+--- a/Makefile
++++ b/Makefile
+@@ -236,7 +236,7 @@ define stringreplace
+ endef
+
+
+-install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
++install: $(build_depsbindir)/stringreplace
+ @$(MAKE) $(QUIET_MAKE) $(JULIA_BUILD_MODE)
+ @for subdir in $(bindir) $(datarootdir)/julia/stdlib/$(VERSDIR) $(docdir) $(man1dir) $(includedir)/julia $(libdir) $(private_libdir) $(sysconfdir) $(private_libexecdir); do \
+ mkdir -p $(DESTDIR)$$subdir; \
diff --git a/dev-lang/julia/files/julia-1.9.4-string-replace.patch b/dev-lang/julia/files/julia-1.9.4-string-replace.patch
new file mode 100644
index 000000000000..7f5497bdac8f
--- /dev/null
+++ b/dev-lang/julia/files/julia-1.9.4-string-replace.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index c742a9f..a38edee 100644
+--- a/Makefile
++++ b/Makefile
+@@ -232,7 +232,7 @@ endif
+ # Note that we disable MSYS2's path munging here, as otherwise
+ # it replaces our `:`-separated list as a `;`-separated one.
+ define stringreplace
+- MSYS2_ARG_CONV_EXCL='*' $(build_depsbindir)/stringreplace $$(strings -t x - '$1' | grep "$2" | awk '{print $$1;}') "$3" 255 "$(call cygpath_w,$1)"
++ MSYS2_ARG_CONV_EXCL='*' $(build_depsbindir)/stringreplace $$(strings -t x - "$1" | grep "$2" | awk '{print $$1;}') "$3" 255 "$(call cygpath_w,$1)"
+ endef
+
+