summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mercury')
-rw-r--r--dev-lang/mercury/Manifest4
-rw-r--r--dev-lang/mercury/mercury-22.01.1.ebuild (renamed from dev-lang/mercury/mercury-20.06.ebuild)31
-rw-r--r--dev-lang/mercury/metadata.xml8
3 files changed, 18 insertions, 25 deletions
diff --git a/dev-lang/mercury/Manifest b/dev-lang/mercury/Manifest
index 92e703f5328d..0d34064a0b84 100644
--- a/dev-lang/mercury/Manifest
+++ b/dev-lang/mercury/Manifest
@@ -1,2 +1,2 @@
-DIST mercury-20.06-gentoo-patchset-1.tar.gz 4555 BLAKE2B 8609ba7cd43d82ceb6b6e25fd6af3b2c750df6446c1235bd9c6f8e3bc87bb1fe0a43cafb9f1d061562bb80ade1deb7809889bf0d703c99ea1e2286bbeb7c5182 SHA512 23fae769c5c1204154c6ed55cc31644967e3554f499b23a6585d34615d062a214d6485de3a4acf8cf90a582a229aeab519e57a6df80cee62e9e6789f210e8256
-DIST mercury-srcdist-20.06.tar.gz 47768559 BLAKE2B f242aa2ef7da53aa2dfa054e4fee8646434d276f0748b014e33ea52d22f2a8a37e6fecaa20617f4943c4c1e7d8c179ed0603a344fde2dd58da98b2bacadf1a71 SHA512 b76bd22d8eb16242c68b614ff122ed7ee7535efef6c0ceb8cc798fee4c550bc41b6faff2135cea43b24c652b654bb35ae049656585d8e7bf3a1122d07cb1ecf4
+DIST mercury-22.01.1-gentoo-patchset-2.tar.gz 4975 BLAKE2B 73dfe5688f7f2c44ee236e3b9fd38811afecc7f8f4dd8f0694c2c3f27ce20a74aade3678bb3a16f7bcfc1fc8b07e518a5954802e410a3f566c00df7898800675 SHA512 16319d2e78af5cb73f67555c1498b277e8c6435cfe4e62fc87817cf06f04deadfad6f8264a5270100aaf6985866b879e9b7c69d3c1839c25d36ca2506bbabd72
+DIST mercury-srcdist-22.01.1.tar.gz 48956249 BLAKE2B 0f5a7662327f27c27a4d9e421f71afa58920f6232093452781124817ce5c34d1953a80a08b75e95101a7e2e88159b7d4ead08d25c67a99abcb908a9582af2bab SHA512 5fa49640307233ea0f641488e5ea526385e52833007a31469e083711b63925ca7568d7ad6e09301ddf7816384a080546bc4cf46b1422f974e008917d1aa4f37a
diff --git a/dev-lang/mercury/mercury-20.06.ebuild b/dev-lang/mercury/mercury-22.01.1.ebuild
index 2a3855fb7950..b56c538277e8 100644
--- a/dev-lang/mercury/mercury-20.06.ebuild
+++ b/dev-lang/mercury/mercury-22.01.1.ebuild
@@ -1,34 +1,36 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools elisp-common eutils flag-o-matic java-pkg-opt-2 multilib vcs-clean xdg-utils
+inherit autotools elisp-common flag-o-matic java-pkg-opt-2 multilib vcs-clean xdg-utils
-PATCHSET_VER="1"
+PATCHSET_VER="2"
MY_P=${PN}-srcdist-${PV}
DESCRIPTION="Mercury is a modern general-purpose logic/functional programming language"
HOMEPAGE="https://www.mercurylang.org/index.html"
-SRC_URI="https://dl.mercurylang.org/release-20.06/${MY_P}.tar.gz
+SRC_URI="https://dl.mercurylang.org/release/${MY_P}.tar.gz
https://dev.gentoo.org/~keri/distfiles/mercury/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug doc emacs erlang examples java mono profile readline threads trail"
+IUSE="debug doc emacs examples java mono profile readline test threads trail"
+RESTRICT="!test? ( test )"
DEPEND="net-libs/libnsl:0=
readline? ( sys-libs/readline:= )
- erlang? ( dev-lang/erlang )
- java? ( >=virtual/jdk-1.6:= )
+ java? ( >=virtual/jdk-1.8:* )
mono? ( dev-lang/mono )
doc? ( sys-apps/texinfo )"
RDEPEND="${DEPEND}
emacs? ( >=app-editors/emacs-23.1:* )"
+BDEPEND="test? ( sys-libs/timezone-data )"
+
S="${WORKDIR}"/${MY_P}
SITEFILE=50${PN}-gentoo.el
@@ -50,7 +52,6 @@ src_configure() {
local myconf
myconf="--libdir=/usr/$(get_libdir) \
$(use_enable mono csharp-grade) \
- $(use_enable erlang erlang-grade) \
$(use_enable java java-grade) \
$(use_enable debug debug-grades) \
$(use_enable profile prof-grades) \
@@ -63,7 +64,7 @@ src_configure() {
src_compile() {
# Prepare mmake flags
- echo "EXTRA_CFLAGS = ${CFLAGS}" >> Mmake.params
+ echo "EXTRA_CFLAGS = ${CFLAGS} -Wno-error" >> Mmake.params
echo "EXTRA_LDFLAGS = ${LDFLAGS}" >> Mmake.params
echo "EXTRA_LD_LIBFLAGS = ${LDFLAGS}" >> Mmake.params
echo "EXTRA_MLFLAGS = --no-strip" >> Mmake.params
@@ -164,14 +165,10 @@ src_install() {
fi
dodoc \
- BUGS HISTORY LIMITATIONS NEWS README README.Linux \
- README.Linux-Alpha README.Linux-m68k README.Linux-PPC \
+ BUGS HISTORY LIMITATIONS.md NEWS README README.md \
+ README.Linux README.Linux-m68k README.Linux-PPC \
RELEASE_NOTES VERSION || die
- if use erlang; then
- dodoc README.Erlang
- fi
-
if use java; then
dodoc README.Java
fi
@@ -181,8 +178,8 @@ src_install() {
fi
if use examples; then
- docinto /usr/share/doc/${PF}/samples
- dodoc samples/{*.m,README,Mmakefile}
+ docinto samples
+ dodoc samples/{*.m,README.md,Mmakefile}
dodoc -r samples/c_interface \
samples/diff \
samples/muz \
diff --git a/dev-lang/mercury/metadata.xml b/dev-lang/mercury/metadata.xml
index 9ecd0bc6506f..5061e4f27e59 100644
--- a/dev-lang/mercury/metadata.xml
+++ b/dev-lang/mercury/metadata.xml
@@ -1,12 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>keri@gentoo.org</email>
- <name>Keri Harris</name>
- </maintainer>
+ <!-- maintainer-needed -->
<use>
- <flag name="erlang">Support Mercury Erlang grade</flag>
<flag name="trail">Support Mercury trail grades</flag>
</use>
</pkgmetadata>