summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/metadata.xml3
-rw-r--r--dev-lang/ocaml/ocaml-4.03.0_beta2.ebuild3
2 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/ocaml/metadata.xml b/dev-lang/ocaml/metadata.xml
index ffac4d7ebc01..aabb331fc977 100644
--- a/dev-lang/ocaml/metadata.xml
+++ b/dev-lang/ocaml/metadata.xml
@@ -5,4 +5,7 @@
<email>ml@gentoo.org</email>
<name>Gentoo ML Project</name>
</maintainer>
+ <use>
+ <flag name="flambda">Enables the Flambda optimizer: A new intermediate representation (introduced in ocaml 4.03) in the depths of the compiler designed to allow for better inlining.</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-lang/ocaml/ocaml-4.03.0_beta2.ebuild b/dev-lang/ocaml/ocaml-4.03.0_beta2.ebuild
index 0aea93c39f97..f795daef3962 100644
--- a/dev-lang/ocaml/ocaml-4.03.0_beta2.ebuild
+++ b/dev-lang/ocaml/ocaml-4.03.0_beta2.ebuild
@@ -18,7 +18,7 @@ LICENSE="QPL-1.0 LGPL-2"
# so here we go with the subslot.
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="emacs latex ncurses +ocamlopt X xemacs"
+IUSE="emacs flambda latex ncurses +ocamlopt X xemacs"
RDEPEND="
ncurses? ( sys-libs/ncurses:0= )
@@ -60,6 +60,7 @@ src_configure() {
use ncurses || myconf="${myconf} -no-curses"
use X || myconf="${myconf} -no-graph"
+ use flambda && myconf="${myconf} -flambda"
# ocaml uses a home-brewn configure script, preventing it to use econf.
RAW_LDFLAGS="$(raw-ldflags)" ./configure \