summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/orc/orc-0.4.33.ebuild')
-rw-r--r--dev-lang/orc/orc-0.4.33.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-lang/orc/orc-0.4.33.ebuild b/dev-lang/orc/orc-0.4.33.ebuild
deleted file mode 100644
index e068104a0ad4..000000000000
--- a/dev-lang/orc/orc-0.4.33.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson-multilib
-
-DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
-HOMEPAGE="https://gstreamer.freedesktop.org/"
-SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="BSD BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-RESTRICT="!test? ( test )"
-IUSE="gtk-doc static-libs test"
-
-DEPEND=""
-RDEPEND=""
-BDEPEND="
- gtk-doc? (
- dev-util/gtk-doc
- app-text/docbook-xml-dtd:4.1.2
- app-text/docbook-xml-dtd:4.3 )
-"
-
-multilib_src_configure() {
- # FIXME: handle backends per arch? What about cross-compiling for the other arches?
- local emesonargs=(
- -Ddefault_library=$(usex static-libs both shared)
- -Dorc-backend=all
- -Dorc-test=enabled # FIXME: always installs static library, bug 645232
- -Dbenchmarks=disabled
- -Dexamples=disabled
- $(meson_native_use_feature gtk-doc gtk_doc)
- $(meson_feature test tests)
- -Dtools=enabled # requires orc-test
- )
- meson_src_configure
-}