summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/pcc/pcc-1.1.0-r1.ebuild')
-rw-r--r--dev-lang/pcc/pcc-1.1.0-r1.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/dev-lang/pcc/pcc-1.1.0-r1.ebuild b/dev-lang/pcc/pcc-1.1.0-r1.ebuild
index e360baaad232..b4e31f8eea76 100644
--- a/dev-lang/pcc/pcc-1.1.0-r1.ebuild
+++ b/dev-lang/pcc/pcc-1.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils versionator autotools
+inherit autotools flag-o-matic
DESCRIPTION="pcc portable c compiler"
HOMEPAGE="http://pcc.ludd.ltu.se"
@@ -13,25 +13,21 @@ SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
DEPEND=">=dev-libs/pcc-libs-${PV}"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-multiarch.patch )
+
src_prepare() {
- sed -i -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' configure.ac || die "Failed to fix configure.ac"
- sed -i -e 's/AC_SUBST(strip)//' configure.ac || die "Failed to fix configure.ac more"
+ default
+ sed -i \
+ -e 's/AC_CHECK_PROG(strip,strip,yes,no)//' \
+ -e 's/AC_SUBST(strip)//' configure.ac || die
eautoreconf
- epatch "${FILESDIR}/${P}-multiarch.patch" || die
}
src_configure() {
+ append-cflags -fcommon
econf --disable-stripping
}
-
-src_compile() {
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-}