summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/tcc/tcc-9999.ebuild')
-rw-r--r--dev-lang/tcc/tcc-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-lang/tcc/tcc-9999.ebuild b/dev-lang/tcc/tcc-9999.ebuild
index a6f9afd599ac..c9e9a83a18e4 100644
--- a/dev-lang/tcc/tcc-9999.ebuild
+++ b/dev-lang/tcc/tcc-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_COMMIT="16456168430c9e185dd94b8215aa77d02bbb8a2c"
DESCRIPTION="A very small C compiler for ix86/amd64"
@@ -54,6 +54,13 @@ src_prepare() {
}
src_configure() {
+ # fails tests
+ # https://bugs.gentoo.org/866815
+ #
+ # Also distributes static libraries:
+ # https://bugs.gentoo.org/926120
+ filter-lto
+
local libc
use test && unset CFLAGS LDFLAGS # Tests run with CC=tcc etc, they will fail hard otherwise