summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/typescript/typescript-5.0.2.ebuild')
-rw-r--r--dev-lang/typescript/typescript-5.0.2.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-lang/typescript/typescript-5.0.2.ebuild b/dev-lang/typescript/typescript-5.0.2.ebuild
deleted file mode 100644
index 7857fd2f036d..000000000000
--- a/dev-lang/typescript/typescript-5.0.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
-HOMEPAGE="https://www.typescriptlang.org/
- https://github.com/microsoft/TypeScript/"
-SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
-S="${WORKDIR}"/package
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64"
-
-RDEPEND="net-libs/nodejs"
-BDEPEND=">=net-libs/nodejs-16[npm]"
-
-src_compile() {
- # Skip, nothing to compile here.
- :
-}
-
-src_install() {
- local myopts=(
- --audit false
- --color false
- --foreground-scripts
- --global
- --offline
- --omit dev
- --prefix "${ED}"/usr
- --progress false
- --verbose
- )
- npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
-
- dodoc *.md *.txt
-}