summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/typescript')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/metadata.xml19
-rw-r--r--dev-lang/typescript/typescript-5.4.5.ebuild39
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
new file mode 100644
index 000000000000..c5666049d890
--- /dev/null
+++ b/dev-lang/typescript/Manifest
@@ -0,0 +1 @@
+DIST typescript-5.4.5.tgz 5825770 BLAKE2B aea24c0924b2a0b0d01face2ce6be4e7fac85c2205cb0ecde492c5301f83d55fd8cd501326bd47f90cd78abf48c7aaf0381b13fc8242f3d2f9235e6051860b2b SHA512 bdc23852946083cd68211505c11d164881cab75d6727b48056560d22ef90a6a7b25cffa0a50272fd9e3e174686c5213832ac23c97bd6fd3ce090b031d80187c1
diff --git a/dev-lang/typescript/metadata.xml b/dev-lang/typescript/metadata.xml
new file mode 100644
index 000000000000..c9f2e5b5a6f4
--- /dev/null
+++ b/dev-lang/typescript/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ TypeScript is a language for application-scale JavaScript. TypeScript adds
+ optional types to JavaScript that support tools for large-scale JavaScript
+ applications for any browser, for any host, on any OS. TypeScript compiles
+ to readable, standards-based JavaScript
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/microsoft/TypeScript/issues/</bugs-to>
+ <remote-id type="github">microsoft/TypeScript</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lang/typescript/typescript-5.4.5.ebuild b/dev-lang/typescript/typescript-5.4.5.ebuild
new file mode 100644
index 000000000000..761177a3441e
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.4.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}