summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/yap')
-rw-r--r--dev-lang/yap/Manifest1
-rw-r--r--dev-lang/yap/files/yap-6.3.3-fix-gcc9.patch27
-rw-r--r--dev-lang/yap/yap-6.3.3-r1.ebuild8
3 files changed, 4 insertions, 32 deletions
diff --git a/dev-lang/yap/Manifest b/dev-lang/yap/Manifest
index 8442192bac1e..9718e707adf8 100644
--- a/dev-lang/yap/Manifest
+++ b/dev-lang/yap/Manifest
@@ -1,2 +1,3 @@
DIST yap-6.3.3-gentoo-patchset-11.tar.gz 6021 BLAKE2B d83682de9a6f095482db66f4fd5bb562739121b8502464d92fb784c634bfbfc020ae3ec55641aaeb8c0d52ce5534f7888bdd7d3d556f68c749b2f0ee35860764 SHA512 d9645a6f5c2b633fb5b61f8b6219ac69ae28e4f53f149fcdbb161cb7a8226aecab64f831a19e73876eb5056bb9efc3501fe792b6dca418a2a56b058ec658a2db
+DIST yap-6.3.3-gentoo-patchset-12.tar.gz 6478 BLAKE2B 405f7a080c670ef1ca246bd60fc6a29aaff5e0c0b2323adef2eff7eb471a79e59a043c2348b8db0f9a70e7d858068cd4c5d51ad9ff13159186ff157e0272ffb1 SHA512 39dc3397ce59e34b4ee82ef9105c0493483f7db4b6018db5ca7f41b0af55f9102fa326bcb79cc3e766fa9faabda17807caf76cfdbbced7905b44749078ee8732
DIST yap-6.3.3.tar.gz 7879301 BLAKE2B 1b12a3113dd57634df64680726fd49575979b84126a7a9e1f4d1429be90e1b95599166151ffe62c9ef990ac3c32f57a1efae081b864fc22225c93d21807f412b SHA512 4ef45277ec84b6e072fa54afc7d6c18f11c3a0cdf477e35e35a0ce2181c9ff2e693f8735f63a1899373f6baf79ce0a972b37e1ae6ed8271bec60663f477bbe80
diff --git a/dev-lang/yap/files/yap-6.3.3-fix-gcc9.patch b/dev-lang/yap/files/yap-6.3.3-fix-gcc9.patch
deleted file mode 100644
index f16d29142215..000000000000
--- a/dev-lang/yap/files/yap-6.3.3-fix-gcc9.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://bugs.gentoo.org/686048
-
-./SolverTypes.h:122:20: error: friend declaration of ‘Clause* Clause_new(const V&, bool)’ specifies default arguments and isn’t a definition [-fpermissive]
- 122 | friend Clause* Clause_new(const V& ps, bool learnt = false);
- | ^~~~~~~~~~
-
---- a/packages/swi-minisat2/C/SolverTypes.h
-+++ b/packages/swi-minisat2/C/SolverTypes.h
-@@ -97,6 +97,9 @@
- //=================================================================================================
- // Clause -- a simple class for representing a clause:
-
-+class Clause;
-+template<class V>
-+Clause* Clause_new(const V& ps, bool learnt = false);
-
- class Clause {
- uint32_t size_etc;
-@@ -119,7 +122,7 @@
-
- // -- use this function instead:
- template<class V>
-- friend Clause* Clause_new(const V& ps, bool learnt = false);
-+ friend Clause* Clause_new(const V& ps, bool learnt);
-
- int size () const { return size_etc >> 3; }
- void shrink (int i) { assert(i <= size()); size_etc = (((size_etc >> 3) - i) << 3) | (size_etc & 7); }
diff --git a/dev-lang/yap/yap-6.3.3-r1.ebuild b/dev-lang/yap/yap-6.3.3-r1.ebuild
index 3864fe27707b..d8893f8b612b 100644
--- a/dev-lang/yap/yap-6.3.3-r1.ebuild
+++ b/dev-lang/yap/yap-6.3.3-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit flag-o-matic java-pkg-opt-2
-PATCHSET_VER="11"
+PATCHSET_VER="12"
DESCRIPTION="YAP is a high-performance Prolog compiler"
HOMEPAGE="http://www.dcc.fc.up.pt/~vsc/Yap/"
@@ -29,10 +29,7 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
doc? ( app-text/texi2html )"
-PATCHES=(
- "${WORKDIR}"/${PV}
- "${FILESDIR}"/${PN}-6.3.3-fix-gcc9.patch
-)
+PATCHES=( "${WORKDIR}"/${PV} )
src_prepare() {
default
@@ -64,6 +61,7 @@ src_configure() {
econf \
--libdir=/usr/$(get_libdir) \
+ --disable-chr \
--disable-prism \
--disable-gecode \
$(use_enable !static dynamic-loading) \