summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/kotlin-bin/Manifest1
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild59
-rw-r--r--dev-lang/kotlin-bin/metadata.xml19
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
new file mode 100644
index 000000000000..a24e82787dbc
--- /dev/null
+++ b/dev-lang/kotlin-bin/Manifest
@@ -0,0 +1 @@
+DIST kotlin-compiler-1.9.22.zip 91026092 BLAKE2B 2fc776b27e30a9d75640dc8fc004bfec5207b1b79c2742aa6a8a75971a8b41310cc16712d6d0921e1fa7545031a75ca8256c48f5c1e13f4e36d82df2574d5699 SHA512 d0e1bdfb1918f007444b1cef6e0c29c2c1846819edd60d016ed62327ea6d2cb505aa18658f916f88b91d9fbdfe0b155ad3361728d6a7a9062806d982bc9b8c6c
diff --git a/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild b/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild
new file mode 100644
index 000000000000..7e3629cfadfc
--- /dev/null
+++ b/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 wrapper
+
+DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
+HOMEPAGE="https://kotlinlang.org/
+ https://github.com/JetBrains/kotlin/"
+SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
+S="${WORKDIR}/kotlinc"
+
+LICENSE="Apache-2.0 BSD MIT NPL-1.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm bin/*.bat || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ # Follow the Java eclass JAR installation path.
+ local app_home="/usr/share/${PN}"
+
+ exeinto "${app_home}/bin"
+ doexe bin/*
+
+ local -a exes=(
+ kapt
+ kotlin
+ kotlinc
+ kotlinc-js
+ kotlinc-jvm
+ kotlin-dce-js
+ )
+ local exe
+ for exe in "${exes[@]}" ; do
+ make_wrapper "${exe}" "${app_home}/bin/${exe}"
+ done
+}
diff --git a/dev-lang/kotlin-bin/metadata.xml b/dev-lang/kotlin-bin/metadata.xml
new file mode 100644
index 000000000000..96b80b4a00c2
--- /dev/null
+++ b/dev-lang/kotlin-bin/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Kotlin is a statically typed language that targets the JVM and JavaScript.
+ It is a general-purpose language intended for industry use. It is developed
+ by a team at JetBrains although it is an OSS language and has external
+ contributors.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/JetBrains/kotlin/issues/</bugs-to>
+ <remote-id type="github">JetBrains/kotlin</remote-id>
+ </upstream>
+</pkgmetadata>