summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/execline/Manifest2
-rw-r--r--dev-lang/execline/execline-2.9.1.0.ebuild47
-rw-r--r--dev-lang/execline/execline-2.9.2.0.ebuild47
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-lang/execline/Manifest b/dev-lang/execline/Manifest
index 130ed38d5a92..86e8e80768bc 100644
--- a/dev-lang/execline/Manifest
+++ b/dev-lang/execline/Manifest
@@ -1,5 +1,3 @@
DIST execline-2.9.0.1.tar.gz 100330 BLAKE2B c6d346700c5ca94ee83163b5ff5c7f0461d61a768345a1ed5cd64d75f10429d241ed007de7a09954774c4f9bec78c8b1bdcd77f8b98a399d10e90e5639d06d7d SHA512 8115a7e0e83789cfd85750fc8e96eea0201dbf6f7d1f194e5c0a008ebf40d8fad8b802a5209d3fe9805eeb9b7542af306d5328e159a15bd7425a64ef1a51ebc3
-DIST execline-2.9.1.0.tar.gz 106227 BLAKE2B 5a8fb4dfda515ba1d7699fdc49bffc2764ae4322c6dc601a9f0fac0dbd6098b466105625b8f066a5696201d0ca7eb4a9f811f6bdac8ac453ea5e4974af324084 SHA512 868cf7d2b99078b34e56c535d7cbcc2d7c6a85501f1cc5cd093ccd868906a2d2f52b872b8f60402d2c98ffc2e3145cc99ce392f3caf334f88decd8f17597b50d
-DIST execline-2.9.2.0.tar.gz 109239 BLAKE2B c274aef7672781de150ccfc6cc2f3907139274b68cdb2c4b62e6618491e797e965a768eb9ddd6eaba8ea33e04467b191b1650729350b373fa6b252b670bb9885 SHA512 74c587f49eb2cfae298e0a9f0a2de4eb4d85a03e66093c14b3c3026bc1b0350f5a8edcaec69636d421484a9edd68bba6999823e04e1c7aff06943a266ad7e0e4
DIST execline-2.9.2.1.tar.gz 109290 BLAKE2B 55eeed28e9663f9a13ee31c4117436ad03c87323525201f66dfc552a0bb17831e4d5e3fddfbcfc9d490c209d0305f47a3a47399e2a6590146f2a0996df2dd42a SHA512 6dbe37fd73ec0bba89e1fc539e27f34fdbcf6028a4053e762cd21036e1a131e0156022bf84467ecba3cdbb4dfba7ee30574283d31e7e228e175775e8e16c1000
DIST execline-2.9.3.0.tar.gz 109536 BLAKE2B ad5361fff5da661c90965d1a9afeecc71225ccbacebe8e44293502ddaa24ca2b98903269d482bf52d2386727bf57e011614cc56bb23219ab32a54f23f5df15e7 SHA512 a71a34896f2186e27959d84222ffefa15d2e43c802ad2c71a0442ee04be73aebe629079e31946ca776975e676a05840ce343e1a97f61bf420dad2cd450a948f2
diff --git a/dev-lang/execline/execline-2.9.1.0.ebuild b/dev-lang/execline/execline-2.9.1.0.ebuild
deleted file mode 100644
index 4d9e7153df7e..000000000000
--- a/dev-lang/execline/execline-2.9.1.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A non-interactive scripting language"
-HOMEPAGE="https://www.skarnet.org/software/execline/"
-SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~riscv ~x86"
-
-RDEPEND=">=dev-libs/skalibs-2.13.0.0:="
-DEPEND="${RDEPEND}"
-
-HTML_DOCS=( doc/. )
-
-src_prepare() {
- default
-
- # Avoid QA warning for LDFLAGS addition
- sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
-
- sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
-}
-
-src_configure() {
- tc-export AR CC RANLIB
-
- local myconf=(
- --bindir=/bin
- --dynlibdir=/usr/$(get_libdir)
- --libdir=/usr/$(get_libdir)/${PN}
- --with-dynlib=/usr/$(get_libdir)
- --with-lib=/usr/$(get_libdir)/skalibs
- --with-sysdeps=/usr/$(get_libdir)/skalibs
- --enable-shared
- --disable-allstatic
- --disable-static
- --disable-static-libc
- )
-
- econf "${myconf[@]}"
-}
diff --git a/dev-lang/execline/execline-2.9.2.0.ebuild b/dev-lang/execline/execline-2.9.2.0.ebuild
deleted file mode 100644
index fd780a03f32c..000000000000
--- a/dev-lang/execline/execline-2.9.2.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A non-interactive scripting language"
-HOMEPAGE="https://www.skarnet.org/software/execline/"
-SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~riscv x86"
-
-RDEPEND=">=dev-libs/skalibs-2.13.0.0:="
-DEPEND="${RDEPEND}"
-
-HTML_DOCS=( doc/. )
-
-src_prepare() {
- default
-
- # Avoid QA warning for LDFLAGS addition
- sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
-
- sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
-}
-
-src_configure() {
- tc-export AR CC RANLIB
-
- local myconf=(
- --bindir=/bin
- --dynlibdir="/$(get_libdir)"
- --libdir="/usr/$(get_libdir)/${PN}"
- --with-dynlib="/$(get_libdir)"
- --with-lib="/usr/$(get_libdir)/skalibs"
- --with-sysdeps="/usr/$(get_libdir)/skalibs"
- --enable-shared
- --disable-allstatic
- --disable-static
- --disable-static-libc
- )
-
- econf "${myconf[@]}"
-}