summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/DirectFB/files')
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch50
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch22
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.6.3-setregion.patch85
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.1-build.patch27
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.5-flags.patch63
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.6-cle266.patch13
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch57
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch33
8 files changed, 0 insertions, 350 deletions
diff --git a/dev-libs/DirectFB/files/DirectFB-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch b/dev-libs/DirectFB/files/DirectFB-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch
deleted file mode 100644
index 06f56fed39d7..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.6.3-atomic-fix-compiler-error-when-building-for-thumb2.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 253e1d0d10bdece158f8f68dc48c19ab57d2da29 Mon Sep 17 00:00:00 2001
-From: Mandeep Singh Baines <msb@chromium.org>
-Date: Mon, 18 Mar 2013 19:03:36 -0700
-Subject: [PATCH] atomic: fix compiler error when building for thumb2
-
-Fixed the following error:
-
-{standard input}: Assembler messages:
-{standard input}:179: Error: thumb conditional instruction should be in IT block
--- `strexeq r4,r1,[r2]'
-{standard input}:283: Error: thumb conditional instruction should be in IT block
--- `strexeq r1,r4,[r2]'
-{standard input}:379: Error: thumb conditional instruction should be in IT block
--- `strexeq r1,r2,[r0]'
-make[4]: *** [fifo.lo] Error 1
-
-Fix was to add the appropriate it block.
-
-While I was at it, I optimized the code a bit by:
-
-1) Moved the mov instruction above the ldrex to minimize the number
-of instructions between the ldex and strex as recommeded here:
-http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.dui0552a/BABFFBJB.html
-2) Saved 4 bytes by replacing mov with movs and teq with cmp.
-
-Signed-off-by: Mandeep Singh Baines <msb@chromium.org>
----
- lib/direct/atomic.h | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/lib/direct/atomic.h b/lib/direct/atomic.h
-index 94cb0c9..8dc0dfb 100644
---- a/lib/direct/atomic.h
-+++ b/lib/direct/atomic.h
-@@ -191,9 +191,10 @@ static inline int _D__atomic_cmpxchg(volatile int *ptr, int old, int _new)
-
- do {
- __asm__ __volatile__("@ atomic_cmpxchg\n"
-+ "movs %0, #0\n"
- "ldrex %1, [%2]\n"
-- "mov %0, #0\n"
-- "teq %1, %3\n"
-+ "cmp %1, %3\n"
-+ "it eq\n"
- "strexeq %0, %4, [%2]\n"
- : "=&r" (res), "=&r" (oldval)
- : "r" (ptr), "Ir" (old), "r" (_new)
---
-1.7.12.4
-
diff --git a/dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch b/dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch
deleted file mode 100644
index 2c71bc96f9e6..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.6.3-pkgconfig.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-http://bugs.gentoo.org/200661
-
---- DirectFB/directfb-config.in
-+++ DirectFB/directfb-config.in
-@@ -300,7 +300,7 @@
- libs="$libs -ldirectfb -lfusion -ldirect @THREADLIB@"
-
- if test -n "$echo_static"; then
-- libs="$libs @DYNLIB@ @ZLIB_LIBS@"
-+ libs="$libs @DYNLIB@ @ZLIB_LIBS@ @SYSFS_LIBS@"
- fi
- fi
-
---- DirectFB/directfb.pc.in
-+++ DirectFB/directfb.pc.in
-@@ -9,5 +9,5 @@
- Version: @VERSION@
- Requires: @DEP_VOODOO@ fusion direct
- Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
--Libs.private: -L${libdir} @LIBM@ @DYNLIB@ @ZLIB_LIBS@
-+Libs.private: -L${libdir} @LIBM@ @DYNLIB@ @ZLIB_LIBS@ @SYSFS_LIBS@
- Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
diff --git a/dev-libs/DirectFB/files/DirectFB-1.6.3-setregion.patch b/dev-libs/DirectFB/files/DirectFB-1.6.3-setregion.patch
deleted file mode 100644
index 8d25a51920d7..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.6.3-setregion.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-https://build.opensuse.org/package/view_file?expand=1&file=DirectFB-setregion.patch&package=DirectFB&project=openSUSE%3AFactory
-
---- gfxdrivers/cyber5k/cyber5k.c
-+++ gfxdrivers/cyber5k/cyber5k.c
-@@ -636,7 +636,8 @@ osdSetRegion( CoreLayer
- CoreLayerRegionConfigFlags updated,
- CoreSurface *surface,
- CorePalette *palette,
-- CoreSurfaceBufferLock *lock )
-+ CoreSurfaceBufferLock *left_lock,
-+ CoreSurfaceBufferLock *right_lock )
- {
- DFBResult ret;
-
-@@ -644,7 +645,7 @@ osdSetRegion( CoreLayer
- ret = oldPrimaryFuncs.SetRegion( layer, oldPrimaryDriverData,
- layer_data, region_data,
- config, updated, surface,
-- palette, lock );
-+ palette, left_lock, right_lock );
- if (ret)
- return ret;
-
---- gfxdrivers/radeon/radeon_crtc1.c
-+++ gfxdrivers/radeon/radeon_crtc1.c
-@@ -147,14 +147,15 @@ crtc1SetRegion( CoreLayer
- CoreLayerRegionConfigFlags updated,
- CoreSurface *surface,
- CorePalette *palette,
-- CoreSurfaceBufferLock *lock )
-+ CoreSurfaceBufferLock *left_lock,
-+ CoreSurfaceBufferLock *right_lock )
- {
-
- if (updated & ~CLRCF_OPTIONS) {
- return OldPrimaryLayerFuncs.SetRegion( layer,
- OldPrimaryLayerDriverData,
- layer_data, region_data,
-- config, updated, surface, palette, lock );
-+ config, updated, surface, palette, left_lock, right_lock );
- }
-
- return DFB_OK;
---- gfxdrivers/cle266/uc_primary.c
-+++ gfxdrivers/cle266/uc_primary.c
-@@ -138,7 +138,8 @@ osdSetRegion( CoreLayer
- CoreLayerRegionConfigFlags updated,
- CoreSurface *surface,
- CorePalette *palette,
-- CoreSurfaceBufferLock *lock )
-+ CoreSurfaceBufferLock *left_lock,
-+ CoreSurfaceBufferLock *right_lock )
- {
- DFBResult ret;
- UcDriverData *ucdrv = (UcDriverData*) driver_data;
-@@ -147,7 +148,7 @@ osdSetRegion( CoreLayer
- ret = ucOldPrimaryFuncs.SetRegion( layer, ucOldPrimaryDriverData,
- layer_data, region_data,
- config, updated, surface,
-- palette, lock );
-+ palette, left_lock, right_lock );
- if (ret)
- return ret;
-
---- gfxdrivers/unichrome/uc_primary.c
-+++ gfxdrivers/unichrome/uc_primary.c
-@@ -135,7 +135,8 @@ osdSetRegion( CoreLayer
- CoreLayerRegionConfigFlags updated,
- CoreSurface *surface,
- CorePalette *palette,
-- CoreSurfaceBufferLock *lock )
-+ CoreSurfaceBufferLock *left_lock,
-+ CoreSurfaceBufferLock *right_lock )
- {
- DFBResult ret;
- UcDriverData *ucdrv = (UcDriverData*) driver_data;
-@@ -144,7 +145,7 @@ osdSetRegion( CoreLayer
- ret = ucOldPrimaryFuncs.SetRegion( layer, ucOldPrimaryDriverData,
- layer_data, region_data,
- config, updated, surface,
-- palette, lock );
-+ palette, left_lock, right_lock );
- if (ret)
- return ret;
-
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.1-build.patch b/dev-libs/DirectFB/files/DirectFB-1.7.1-build.patch
deleted file mode 100644
index 28c92eb79b02..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.7.1-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Author: hasufell <hasufell@gentoo.org>
-Date: Sat Dec 28 23:52:03 2013 +0100
-
- * INCLUDES is deprecated, use AM_CPPFLAGS instead
- * add missing SVG_CFLAGS
-
---- a/interfaces/IDirectFBImageProvider/Makefile.am
-+++ b/interfaces/IDirectFBImageProvider/Makefile.am
-@@ -77,15 +77,14 @@ else
- FFMPEG_PROVIDER_LTLIB =
- endif
-
--INCLUDES = \
-+AM_CPPFLAGS = \
- -I$(top_builddir)/include \
- -I$(top_builddir)/lib \
- -I$(top_builddir)/src \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/lib \
-- -I$(top_srcdir)/src
--
--AM_CPPFLAGS = -DDATADIR=\"${RUNTIME_SYSROOT}@DATADIR@\" $(LIBJPEG_CFLAGS) $(LIBPNG_CFLAGS) $(FFMPEG_CFLAGS)
-+ -I$(top_srcdir)/src \
-+ -DDATADIR=\"${RUNTIME_SYSROOT}@DATADIR@\" $(LIBJPEG_CFLAGS) $(LIBPNG_CFLAGS) $(FFMPEG_CFLAGS) $(SVG_CFLAGS)
-
- idirectfbimageprovider_LTLIBRARIES = \
- libidirectfbimageprovider_dfiff.la \
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.5-flags.patch b/dev-libs/DirectFB/files/DirectFB-1.7.5-flags.patch
deleted file mode 100644
index 485cd1934fc6..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.7.5-flags.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Author: hasufell <hasufell@gentoo.org>
-Date: Sat Dec 28 23:48:53 2013 +0100
-
- * respect system flags
- * remove Werror, it breaks the build
-
---- a/configure.in
-+++ b/configure.in
-@@ -194,12 +194,7 @@ AM_CONDITIONAL(X11VDPAU_CORE, test "$enable_x11vdpau" = "yes")
- AC_CHECK_HEADERS(linux/compiler.h linux/unistd.h asm/page.h signal.h)
-
-
--dnl Clear default CFLAGS
--if test x"$CFLAGS" = x"-g -O2"; then
-- CFLAGS=
--fi
--
--CFLAGS="-ffast-math -pipe $CFLAGS"
-+CFLAGS="-ffast-math $CFLAGS"
-
- DFB_INTERNAL_CFLAGS="-D_GNU_SOURCE $DFB_INTERNAL_CFLAGS"
-
-@@ -467,7 +462,7 @@ AC_ARG_ENABLE(debug,
- [enable debugging @<:@default=no@:>@]),
- [], [enable_debug=no])
- if test "$enable_debug" = "yes"; then
-- CFLAGS="-g3 -O0 -fno-inline -Wno-inline $CFLAGS"
-+ CFLAGS="-fno-inline -Wno-inline $CFLAGS"
- DIRECT_BUILD_DEBUG=1
- else
- DIRECT_BUILD_DEBUG=0
-@@ -483,13 +478,8 @@ AC_ARG_ENABLE(debug-support,
- [], [enable_debug_support=yes])
- if test "$enable_debug_support" = "yes" || test "$enable_debug" = "yes"; then
- enable_debug_support=yes
-- if test "$enable_debug" = "no"; then
-- CFLAGS="-g2 $CFLAGS"
-- fi
-- CFLAGS="-O3 $CFLAGS"
- DIRECT_BUILD_DEBUGS=1
- else
-- CFLAGS="-O3 -g0 $CFLAGS"
- DIRECT_BUILD_DEBUGS=0
- fi
- AM_CONDITIONAL(ENABLE_DEBUGS, test "$enable_debug_support" = "yes")
-@@ -2750,8 +2750,6 @@
-
- AS_AC_EXPAND(SYSCONFDIR, $sysconfdir)
-
--CFLAGS="$CFLAGS -Werror-implicit-function-declaration"
--
- AC_ARG_ENABLE(extra-warnings,
- AC_HELP_STRING([--enable-extra-warnings],
- [enable extra warnings @<:@default=no@:>@]),
-@@ -2761,7 +2759,7 @@
- fi
-
- if test "$GCC" = "yes"; then
-- CFLAGS="-Wall -Wstrict-prototypes -Wmissing-prototypes -Wno-strict-aliasing -Werror-implicit-function-declaration $CFLAGS"
-+ CFLAGS="-Wall -Wstrict-prototypes -Wmissing-prototypes -Wno-strict-aliasing $CFLAGS"
- CXXFLAGS="-Wall -Wno-strict-aliasing -std=$CXXSTD $CXXFLAGS"
- fi
-
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.6-cle266.patch b/dev-libs/DirectFB/files/DirectFB-1.7.6-cle266.patch
deleted file mode 100644
index ff72f5339dbf..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.7.6-cle266.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/527986
-
---- a/gfxdrivers/cle266/uc_overlay.c 2015-02-10 15:26:24.931309401 -0800
-+++ b/gfxdrivers/cle266/uc_overlay.c 2015-02-10 15:26:47.229309401 -0800
-@@ -246,7 +246,7 @@
- dfb_surface_flip(surface, false);
-
- ucovl->field = 0;
-- ucovl->lock = lock;
-+ ucovl->lock = left_lock;
-
- ret = uc_ovl_update(ucdrv, ucovl, UC_OVL_FLIP, surface, left_lock);
- if (ret)
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch b/dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch
deleted file mode 100644
index 561db23aeeda..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.7.6-idivine.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- lib/divine/idivine.h.orig
-+++ lib/divine/idivine.h
-@@ -0,0 +1,54 @@
-+/*
-+ (c) Copyright 2012-2013 DirectFB integrated media GmbH
-+ (c) Copyright 2001-2013 The world wide DirectFB Open Source Community (directfb.org)
-+ (c) Copyright 2000-2004 Convergence (integrated media) GmbH
-+
-+ All rights reserved.
-+
-+ Written by Denis Oliver Kropp <dok@directfb.org>,
-+ Andreas Shimokawa <andi@directfb.org>,
-+ Marek Pikarski <mass@directfb.org>,
-+ Sven Neumann <neo@directfb.org>,
-+ Ville Syrjälä <syrjala@sci.fi> and
-+ Claudio Ciccani <klan@users.sf.net>.
-+
-+ This library is free software; you can redistribute it and/or
-+ modify it under the terms of the GNU Lesser General Public
-+ License as published by the Free Software Foundation; either
-+ version 2 of the License, or (at your option) any later version.
-+
-+ This library is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ Lesser General Public License for more details.
-+
-+ You should have received a copy of the GNU Lesser General Public
-+ License along with this library; if not, write to the
-+ Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-+ Boston, MA 02111-1307, USA.
-+*/
-+
-+
-+
-+#ifndef __IDIVINE_H__
-+#define __IDIVINE_H__
-+
-+#include <divine.h>
-+
-+/*
-+ * private data struct of IDiVine
-+ */
-+typedef struct {
-+ int ref; /* reference counter */
-+
-+ DiVine *divine;
-+} IDiVine_data;
-+
-+/*
-+ * IDiVine constructor/destructor
-+ */
-+DFBResult IDiVine_Construct( IDiVine *thiz );
-+
-+void IDiVine_Destruct ( IDiVine *thiz );
-+
-+#endif
diff --git a/dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch b/dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch
deleted file mode 100644
index 3315968bc092..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.7.6-tslib.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/deniskropp/DirectFB/pull/6
-https://bugs.gentoo.org/567294
-
-From 5c7c4b197b9d04587b05624db4cfca6503adb3ff Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Thu, 8 Dec 2016 16:47:34 -0500
-Subject: [PATCH] configure: fix tslib version check
-
-The tslib version is 1.0, not 1.0.0. Trying to check for the latter
-fails when using pkg-config:
-$ pkg-config --exists --print-errors "tslib-1.0 >= 1.0"
-$ pkg-config --exists --print-errors "tslib-1.0 >= 1.0.0"
-Requested 'tslib-1.0 >= 1.0.0' but version of tslib is 1.0
----
- configure.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.in b/configure.in
-index 6143cd393699..12a65fdc4f52 100644
---- a/configure.in
-+++ b/configure.in
-@@ -2561,7 +2561,7 @@ fi
-
- enable_tslib=no
- if test "$checkfor_tslib" = "yes"; then
-- PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
-+ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0], [enable_tslib=yes], [enable_tslib=no])
- if test "$enable_tslib" = "no"; then
- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no
- AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
---
-2.11.0.rc2
-