summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aml')
-rw-r--r--dev-libs/aml/Manifest3
-rw-r--r--dev-libs/aml/aml-0.2.0.ebuild28
-rw-r--r--dev-libs/aml/aml-0.3.0.ebuild (renamed from dev-libs/aml/aml-0.2.1.ebuild)14
-rw-r--r--dev-libs/aml/aml-9999.ebuild14
-rw-r--r--dev-libs/aml/files/aml-0.3.0-queue.patch21
-rw-r--r--dev-libs/aml/metadata.xml3
6 files changed, 43 insertions, 40 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
index 26e539a0c75f..908594ea00c8 100644
--- a/dev-libs/aml/Manifest
+++ b/dev-libs/aml/Manifest
@@ -1,2 +1 @@
-DIST aml-0.2.0.tar.gz 20358 BLAKE2B 4be63726ea9069cbfe36fbf04e3a0b2229066d7df039aea1a41fdca27700d012fda9eda348115f8c0ef9d3f201640123722d0b96bc7b171841d920357a292152 SHA512 196cd891fdbaad47340d8b4ca9eb62a7f9e6b0969ae9ad744a3c9ea110a532691d53a1e39fde583bad0f8fdae4b51c3a4243bbdab65e952e5fc79ceb6efc3262
-DIST aml-0.2.1.tar.gz 20413 BLAKE2B 62f8cc0e75f23ac7dc8835dd874f584cdb5b394b0d7af08feded06b99ccff66395e0ec04bdd26917ef7784457dc170c2c99bc98a118ecff947602e4d9a60bf21 SHA512 0af4a50cafbddd2a593dac437e6c8121de5265d0383139818bcda97d672a7430cb410ce32552b6842bc82eaebb061bc6cc0ee1b45a483754efbdfbc2103fa2e3
+DIST aml-0.3.0.tar.gz 21070 BLAKE2B 09b8818ba63eb0f8c36e90385ee0787cad45b80c71cfcf439f93560f56269d52468bbdd2c0e8ad6cbf78b8fd0dd715aa107bfeb3918f55671ffca3f8daab56e3 SHA512 7c3347ef47ace8a14860e2b46937c8ade3712aa75a8c36845594fb4fa6ca26c35320b5234574accff451ea8302f23075acbe1a1b0392f5fbcbbbda20640be1fd
diff --git a/dev-libs/aml/aml-0.2.0.ebuild b/dev-libs/aml/aml-0.2.0.ebuild
deleted file mode 100644
index 0a91a702137c..000000000000
--- a/dev-libs/aml/aml-0.2.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="event timer executor loop"
-HOMEPAGE="https://github.com/any1/aml/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/any1/aml.git"
-else
- SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv ~x86"
-fi
-
-LICENSE="ISC"
-SLOT="0"
-IUSE="examples"
-
-src_configure() {
- local emesonargs=(
- $(meson_use examples)
- )
- meson_src_configure
-}
diff --git a/dev-libs/aml/aml-0.2.1.ebuild b/dev-libs/aml/aml-0.3.0.ebuild
index 5ff10f20992d..37b80ef098ff 100644
--- a/dev-libs/aml/aml-0.2.1.ebuild
+++ b/dev-libs/aml/aml-0.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv ~x86"
+ KEYWORDS="amd64 arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv x86"
fi
LICENSE="ISC"
@@ -22,12 +22,16 @@ IUSE="examples"
DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+PATCHES=(
+ "${FILESDIR}"/${P}-queue.patch
+)
+
src_prepare() {
default
- # The bundled copy includes cdefs which breaks on musl and
- # this header is already available on glibc.
- # bug #828806
+ # The bundled copy includes cdefs which breaks on musl and this header is
+ # already available on glibc. See bug #828806 and
+ # https://github.com/any1/aml/issues/11.
rm include/sys/queue.h || die
}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
index 5ff10f20992d..a7c7dfbf2a1a 100644
--- a/dev-libs/aml/aml-9999.ebuild
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/any1/aml.git"
else
SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~riscv ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~riscv ~x86"
fi
LICENSE="ISC"
@@ -22,12 +22,16 @@ IUSE="examples"
DEPEND="elibc_musl? ( sys-libs/queue-standalone )"
+PATCHES=(
+ "${FILESDIR}"/${P}-queue.patch
+)
+
src_prepare() {
default
- # The bundled copy includes cdefs which breaks on musl and
- # this header is already available on glibc.
- # bug #828806
+ # The bundled copy includes cdefs which breaks on musl and this header is
+ # already available on glibc. See bug #828806 and
+ # https://github.com/any1/aml/issues/11.
rm include/sys/queue.h || die
}
diff --git a/dev-libs/aml/files/aml-0.3.0-queue.patch b/dev-libs/aml/files/aml-0.3.0-queue.patch
new file mode 100644
index 000000000000..299379a934f6
--- /dev/null
+++ b/dev-libs/aml/files/aml-0.3.0-queue.patch
@@ -0,0 +1,21 @@
+The bundled queue.h breaks on musl, but the standard version lacks
+LIST_FOREACH_SAFE, which appears to come from FreeBSD, so patch that back
+in here. See https://github.com/any1/aml/issues/11.
+
+diff -Naur a/src/aml.c b/src/aml.c
+--- a/src/aml.c 2023-01-22 12:57:53.000000000 +0000
++++ b/src/aml.c 2023-03-19 10:10:11.034092428 +0000
+@@ -31,6 +31,13 @@
+ #include "sys/queue.h"
+ #include "thread-pool.h"
+
++#ifndef LIST_FOREACH_SAFE
++#define LIST_FOREACH_SAFE(var, head, field, tvar) \
++ for ((var) = LIST_FIRST((head)); \
++ (var) && ((tvar) = LIST_NEXT((var), field), 1); \
++ (var) = (tvar))
++#endif
++
+ #define EXPORT __attribute__((visibility("default")))
+
+ #define EVENT_MASK_DEFAULT AML_EVENT_READ
diff --git a/dev-libs/aml/metadata.xml b/dev-libs/aml/metadata.xml
index 25cb689305de..3721b93dab05 100644
--- a/dev-libs/aml/metadata.xml
+++ b/dev-libs/aml/metadata.xml
@@ -2,6 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">any1/aml</remote-id>
+ </upstream>
<use>
<flag name="examples">Build and install examples</flag>
</use>