summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/c-capnproto/c-capnproto-0.2.ebuild')
-rw-r--r--dev-libs/c-capnproto/c-capnproto-0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/c-capnproto/c-capnproto-0.2.ebuild b/dev-libs/c-capnproto/c-capnproto-0.2.ebuild
new file mode 100644
index 000000000000..23e6bcb674ef
--- /dev/null
+++ b/dev-libs/c-capnproto/c-capnproto-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils
+
+DESCRIPTION="C library/compiler for the Cap'n Proto serialization/RPC protocol"
+HOMEPAGE="https://github.com/opensourcerouting/c-capnproto"
+SRC_URI="https://github.com/opensourcerouting/c-capnproto/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${DEPEND}
+ test? ( dev-cpp/gtest )"
+S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}/gtest.patch"
+)