summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/capnproto')
-rw-r--r--dev-libs/capnproto/Manifest1
-rw-r--r--dev-libs/capnproto/capnproto-0.10.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/capnproto/Manifest b/dev-libs/capnproto/Manifest
index bedc589fb927..84e5ab808603 100644
--- a/dev-libs/capnproto/Manifest
+++ b/dev-libs/capnproto/Manifest
@@ -1,2 +1,3 @@
DIST capnproto-0.10.2.tar.gz 2279393 BLAKE2B d78442bc122bc976fb636dfde694e10414bf3468ead903fac7ba59cbd81a49ce94969954fdc90f92f7f58f0af80f2da1f70de9b461d99fc6ae9a9e7aa9cd0500 SHA512 079ab715ea19ac207f72bb4874ab6362c11dfb9128342ec937e3f4d27e4100530cf9e6a0275eaca1e45a1bb706b65179a526ea8cfceba93bb36cd6c4f1c0cf5b
+DIST capnproto-0.10.4.tar.gz 2280389 BLAKE2B 3a893b766302a96df71763613fa1624f6b7229b8926099d1d9c217f4a1817db16aa24d3bec7950e480da6b027bd9b6b0b5a4083e982e7bda8fc6594794fd379a SHA512 6179a202399f4391014827799c954e0b3ad811ab82ebd0addc01d8c7695b9c1a9c0a0c26b018cd392e3731e12b30cca58545459d1b3a140e86e34b75d7eacbc7
DIST capnproto-0.9.1.tar.gz 2238849 BLAKE2B f8de56c7f79b0ddad35f3e8fec7740510ca2328e4ddc633a71420901d3fc44df44d807c3965213dfc2535bbe03832c5164242d33cd0bff901d6f288fb62bab21 SHA512 bdc5960f26214139744d768ca4558b085e2d359c375a8849ca532a4c458a2daf0ee1a1f4d00745de5abf353aa1e4084a2d85e5523006f23f591f21fac2d847fd
diff --git a/dev-libs/capnproto/capnproto-0.10.4.ebuild b/dev-libs/capnproto/capnproto-0.10.4.ebuild
new file mode 100644
index 000000000000..1b441c83dfac
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.10.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/091"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:= )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ append-atomic-flags
+ if [[ ${LIBS} == *atomic* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}