summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dbus-glib/dbus-glib-0.110.ebuild')
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.110.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/dbus-glib/dbus-glib-0.110.ebuild b/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
index 6e817d8bfe90..2d3b43af461d 100644
--- a/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
+++ b/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit bash-completion-r1 multilib-minimal toolchain-funcs
+inherit autotools bash-completion-r1 multilib-minimal toolchain-funcs
DESCRIPTION="D-Bus bindings for glib"
HOMEPAGE="https://dbus.freedesktop.org/"
@@ -31,11 +31,18 @@ BDEPEND="
DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+PATCHES=( "${FILESDIR}"/${P}-config-glib-genmarshal.conf )
+
set_TBD() {
# out of sources build dir for make check
export TBD="${BUILD_DIR}-tests"
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
local myconf=(
--localstatedir="${EPREFIX}"/var