summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/eeze/eeze-9999.ebuild')
-rw-r--r--dev-libs/eeze/eeze-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/eeze/eeze-9999.ebuild b/dev-libs/eeze/eeze-9999.ebuild
new file mode 100644
index 000000000000..2bc9039a3e6b
--- /dev/null
+++ b/dev-libs/eeze/eeze-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="library to simplify the use of devices"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eeze"
+
+LICENSE="BSD-2"
+IUSE="static-libs utilities"
+
+DEPEND=">=dev-libs/ecore-${PV}
+ >=dev-libs/eina-${PV}
+ >=dev-libs/eet-${PV}
+ virtual/udev"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ E_ECONF+=(
+ $(use_enable doc)
+ $(use_enable utilities eeze-disk-ls)
+ $(use_enable utilities eeze-mount)
+ $(use_enable utilities eeze-umount)
+ $(use_enable utilities eeze-udev-test)
+ )
+ enlightenment_src_configure
+}