summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ell/ell-9999.ebuild')
-rw-r--r--dev-libs/ell/ell-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-libs/ell/ell-9999.ebuild b/dev-libs/ell/ell-9999.ebuild
index 56c48e4f83d1..8cffe5864e18 100644
--- a/dev-libs/ell/ell-9999.ebuild
+++ b/dev-libs/ell/ell-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic linux-info multilib-minimal
+inherit flag-o-matic linux-info
DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
HOMEPAGE="https://01.org/ell"
@@ -12,7 +12,7 @@ if [[ "${PV}" == *9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/ell/ell.git"
else
SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
LICENSE="LGPL-2.1"
SLOT="0"
@@ -20,7 +20,6 @@ SLOT="0"
IUSE="pie test"
RESTRICT="!test? ( test )"
-RDEPEND=""
DEPEND="test? ( sys-apps/dbus )"
CONFIG_CHECK="
@@ -35,20 +34,21 @@ CONFIG_CHECK="
src_prepare() {
default
+ sed -i -e "s#/tmp/ell-test-bus#/tmp/ell-test-bus-$(uuidgen)#" \
+ unit/test-dbus*.c unit/dbus.conf || die
[[ "${PV}" == *9999 ]] && eautoreconf
}
-multilib_src_configure() {
+src_configure() {
append-cflags "-fsigned-char" #662694
local myeconfargs=(
$(use_enable pie)
)
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}"
}
-multilib_src_install_all() {
- local DOCS=( ChangeLog README )
- einstalldocs
+src_install() {
+ default
find "${ED}" -name "*.la" -delete || die
}