summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/geoip/geoip-1.6.12.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.6.12.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/dev-libs/geoip/geoip-1.6.12.ebuild b/dev-libs/geoip/geoip-1.6.12.ebuild
index 3c6fe0eb74cc..ba375f0038c0 100644
--- a/dev-libs/geoip/geoip-1.6.12.ebuild
+++ b/dev-libs/geoip/geoip-1.6.12.ebuild
@@ -1,40 +1,33 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils ltprune
+EAPI=7
+
+inherit autotools
DESCRIPTION="GeoIP Legacy C API"
HOMEPAGE="https://github.com/maxmind/geoip-api-c"
-SRC_URI="
- https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
-"
+SRC_URI="https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-api-c-${PV}"
# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
LICENSE="LGPL-2.1 GPL-2 MaxMind2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
RESTRICT="test"
-DEPEND="
- net-misc/wget
-"
-RDEPEND="
- ${DEPEND}
-"
-
-S="${WORKDIR}/${PN}-api-c-${PV}"
+DEPEND="net-misc/wget"
+RDEPEND="${DEPEND}"
src_prepare() {
default
-
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
- sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r6.sh > geoipupdate.sh || die
+ sed -e "s|@PREFIX@|${EPREFIX}|g" "${FILESDIR}"/geoipupdate-r6.sh > geoipupdate.sh || die
}
src_install() {
@@ -42,7 +35,7 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS.md README*
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
keepdir /usr/share/GeoIP
@@ -52,6 +45,6 @@ src_install() {
pkg_postinst() {
ewarn "WARNING: Databases are no longer installed by this ebuild."
elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
- elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
+ elog "net-misc/geoipupdate) to populate ${EROOT}/usr/share/GeoIP/"
elog "with geo-located IP address databases."
}