summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gf-complete/gf-complete-0.0.0.ebuild')
-rw-r--r--dev-libs/gf-complete/gf-complete-0.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/gf-complete/gf-complete-0.0.0.ebuild b/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
new file mode 100644
index 000000000000..f19f324f69a0
--- /dev/null
+++ b/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A Comprehensive Open Source Library for Galois Field Arithmetic"
+HOMEPAGE="http://jerasure.org/"
+SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/${P}.tar.gz"
+S="${WORKDIR}/${PN}.git"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/ -O3 $(SIMD_FLAGS)//g' src/Makefile.am tools/Makefile.am test/Makefile.am examples/Makefile.am|| die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}