summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/girara/girara-9999.ebuild')
-rw-r--r--dev-libs/girara/girara-9999.ebuild61
1 files changed, 35 insertions, 26 deletions
diff --git a/dev-libs/girara/girara-9999.ebuild b/dev-libs/girara/girara-9999.ebuild
index 773853805306..6b506349dbaa 100644
--- a/dev-libs/girara/girara-9999.ebuild
+++ b/dev-libs/girara/girara-9999.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson virtualx
DESCRIPTION="UI library that focuses on simplicity and minimalism"
HOMEPAGE="https://pwmt.org/projects/girara/"
-if [[ ${PV} == *999 ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
EGIT_BRANCH="develop"
else
- SRC_URI="https://github.com/pwmt/girara/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://pwmt.org/projects/girara/download/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
fi
LICENSE="ZLIB"
@@ -23,32 +23,41 @@ IUSE="doc libnotify test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/glib:2
- dev-libs/json-c:=
- >=x11-libs/gtk+-3.20:3
- >=x11-libs/pango-1.14
- libnotify? ( x11-libs/libnotify )"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? ( dev-libs/check )"
-
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
- sed -i -e '/'-Werror.*'/d' meson.build || die "sed failed"
-}
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/glib:2
+ dev-libs/json-glib:=
+ media-libs/harfbuzz:=
+ x11-libs/cairo[glib]
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/pango
+ libnotify? ( x11-libs/libnotify )
+"
+# Tests are run under virtx
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-libs/check
+ x11-base/xorg-proto
+ x11-libs/gtk+:3[X]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+"
src_configure() {
- local emesonargs=(
+ local -a emesonargs=(
-Djson=enabled
- -Ddocs=$(usex doc enabled disabled)
- -Dnotify=$(usex libnotify enabled disabled)
- )
- meson_src_configure
+ $(meson_feature doc docs)
+ $(meson_feature libnotify notify)
+ )
+ meson_src_configure
}
src_test() {
+ # TODO: run test on wayland
virtx meson_src_test
}