summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.78.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index f4d1b96d4cbc..77879c0844c6 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -2,3 +2,4 @@ DIST gjs-1.76.2.tar.xz 646232 BLAKE2B 66466eeb5f956d5041f4e63ba977dc9a688455770c
DIST gjs-1.78.0.tar.xz 653500 BLAKE2B f2b6c3d80f55c1b3365fdc94dcedec357fc21ec7f92eccdf24cc028eb006538057d0d6e3328bc2f743a563ba496da5daa8585fabd6fbf52acd38c990b8a4e8ba SHA512 28ad3ff5c031b8e78622244918994ca5f510e4b403a382e7d0b0bcb9a0611be61e103398773328be4c405b49d7984c089180a5fb603518b412d01a935fb3ceb3
DIST gjs-1.78.1.tar.xz 654556 BLAKE2B 1d723ad2fd15e7ba6b9194cb90f0c0bc7b89c150604beb11ad95e1628ead2bea7ed8b423e1836736013a31e8ff8f3e2400458faa26dcc95d3a6dc36c65957583 SHA512 9a5d02bacbf82364cf5daa69d6613eb38ef34121eb350b2773b87cf1027ccc1b9905b651275fd71036817e710d834d356ee1cecac2f7c83ff571c39e98360286
DIST gjs-1.78.3.tar.xz 655236 BLAKE2B d240b394a6b13822fe6332ae65fc5b13d70c62cfad7736308b57abb570e039d6045ed2c646170e4c05ebf62a31d24caccaabe6789c9c951a8b63746b33e20edb SHA512 215893e0247f4c0947b9d1394d08d6664aa9ef43ff40e1fb8453ee0f1be7843758166b17d4b63ff91ac421845e2ad27089879ecb3082d8f4737fb3abf2636223
+DIST gjs-1.78.4.tar.xz 655220 BLAKE2B 0adcc3d0cc88a36b94b2113a6d88ded9be7fa034392fa38abb9ac22a962fb8601a76b6c886500e48c40fbe8708b3164b1d403dd83cd4e77358a4a020e8c15632 SHA512 a402050cee011a84f0ebb6b1512a2e681e792cf559b3182ece0868e57191be64337d6683ebcb8a7ee89ba79c12947a8cbca85f015c6015d26901352b5255c2c4
diff --git a/dev-libs/gjs/gjs-1.78.4.ebuild b/dev-libs/gjs/gjs-1.78.4.ebuild
new file mode 100644
index 000000000000..f9d52d43c6ba
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.78.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.71.1:=
+ dev-lang/spidermonkey:115
+ cairo? ( x11-libs/cairo[X,glib] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}