summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gnulib')
-rw-r--r--dev-libs/gnulib/Manifest3
-rw-r--r--dev-libs/gnulib/gnulib-2022.05.26.07.24.56.ebuild (renamed from dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild)12
-rw-r--r--dev-libs/gnulib/gnulib-2024.01.01.10.31.48.ebuild43
-rw-r--r--dev-libs/gnulib/gnulib-9999-r1.ebuild6
4 files changed, 54 insertions, 10 deletions
diff --git a/dev-libs/gnulib/Manifest b/dev-libs/gnulib/Manifest
index 39d4a175c2a9..66669df08883 100644
--- a/dev-libs/gnulib/Manifest
+++ b/dev-libs/gnulib/Manifest
@@ -1 +1,2 @@
-DIST gnulib-b451121ab45497e78cb6f612c8673a9705193391.tar.gz 6666079 BLAKE2B e7d3b9478697067b57ab198e044f3c854128d5fe390d30947829ce4f34c695a748668c33ae19690e9927fff6df3e194a3160cb4adb7cf47235c603241c66889a SHA512 f6e165cfc0a3999c778d9f43ffc90ff9b569a77ff1e54ff5c50b12b0eddf262c24da8cd2719548574e0397535bb0eb835eef603cc74769f7876ef9db101bebec
+DIST gnulib-5293ada82e1ea38e9e5cdd3724c73204d703f07b.tar.xz 4721720 BLAKE2B d0c70f4f33cbc3b7fcbef6ebe67d4ebac2a89fe8e9b1598fa00f0292ce2bc528ed6f5be123072c43c52f1234266bb6fb96b7881839ff884a39d2bce58a9f3ad7 SHA512 0f1822fb579649c3cd09ca8e69334d425f2024d780a98d7bbf38d26f36f174036fa066635513485ddd6e2ad485c7060ae9b101c1595891307a382e6aa9bc4226
+DIST gnulib-5b92dd0a45c8d27f13a21076b57095ea5e220870.tar.xz 5058128 BLAKE2B 8bf17315962292790a4279fe39a07595656bb5a5b5c7273efe18c4b798dfcbc5ab39eed5b235e8313873b521dfb04998230a879985908ee4e21b59870d52191b SHA512 786c512159db7b0d6905b77ca193397479db94b3ef7ccf96876773b1942fdb7608ab82ceaa16ecba6ed8229de06d844b0d0b7a85dd672f88f46efc3361e28637
diff --git a/dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild b/dev-libs/gnulib/gnulib-2022.05.26.07.24.56.ebuild
index f8ff711142ef..c94405ca93aa 100644
--- a/dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild
+++ b/dev-libs/gnulib/gnulib-2022.05.26.07.24.56.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-GIT_TAG="b451121ab45497e78cb6f612c8673a9705193391"
+GIT_TAG="5293ada82e1ea38e9e5cdd3724c73204d703f07b"
DESCRIPTION="Library of common routines intended to be shared"
HOMEPAGE="https://www.gnu.org/software/gnulib"
-SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.gz"
+SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.xz"
-LICENSE="GPL-2"
+LICENSE="GPL-3+ LGPL-2.1+ FDL-1.3+"
SLOT="0"
-KEYWORDS="~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~arm64-macos ~x64-macos ~x64-solaris"
IUSE="doc"
S="${WORKDIR}/${PN}-${GIT_TAG}"
diff --git a/dev-libs/gnulib/gnulib-2024.01.01.10.31.48.ebuild b/dev-libs/gnulib/gnulib-2024.01.01.10.31.48.ebuild
new file mode 100644
index 000000000000..fca8f100970f
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-2024.01.01.10.31.48.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GIT_TAG="5b92dd0a45c8d27f13a21076b57095ea5e220870"
+
+DESCRIPTION="Library of common routines intended to be shared"
+HOMEPAGE="https://www.gnu.org/software/gnulib"
+SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.xz"
+
+LICENSE="GPL-3+ LGPL-2.1+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~arm64-macos ~x64-macos ~x64-solaris"
+IUSE="doc"
+
+S="${WORKDIR}/${PN}-${GIT_TAG}"
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html
+ fi
+}
+
+src_install() {
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins -r build-aux
+ doins -r doc
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r tests
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym ../share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+}
diff --git a/dev-libs/gnulib/gnulib-9999-r1.ebuild b/dev-libs/gnulib/gnulib-9999-r1.ebuild
index 394e16ee666b..10bc9a526f5a 100644
--- a/dev-libs/gnulib/gnulib-9999-r1.ebuild
+++ b/dev-libs/gnulib/gnulib-9999-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit git-r3
@@ -9,7 +9,7 @@ DESCRIPTION="Gnulib is a library of common routines intended to be shared at the
HOMEPAGE="https://www.gnu.org/software/gnulib"
EGIT_REPO_URI="https://git.savannah.gnu.org/r/${PN}.git"
-LICENSE="GPL-2"
+LICENSE="GPL-3+ LGPL-2.1+ FDL-1.3+"
SLOT="0"
KEYWORDS=""
IUSE="doc"