summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/hidapi/hidapi-0.13.1.ebuild')
-rw-r--r--dev-libs/hidapi/hidapi-0.13.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-libs/hidapi/hidapi-0.13.1.ebuild b/dev-libs/hidapi/hidapi-0.13.1.ebuild
deleted file mode 100644
index a3fea97f574b..000000000000
--- a/dev-libs/hidapi/hidapi-0.13.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
-HOMEPAGE="https://github.com/libusb/hidapi"
-SRC_URI="https://github.com/libusb/hidapi/archive/${P}.tar.gz -> ${P}.tgz"
-
-LICENSE="|| ( BSD GPL-3 HIDAPI )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
-IUSE="doc"
-
-DEPEND="
- virtual/libusb:1[${MULTILIB_USEDEP}]
- virtual/libudev:0[${MULTILIB_USEDEP}]"
-RDEPEND="${DEPEND}"
-BDEPEND="
- doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${PN}-${P}"
-
-multilib_src_compile() {
- cmake_src_compile
-
- if use doc && multilib_is_native_abi; then
- cd "${S}/doxygen"
- doxygen Doxyfile || die
- fi
-}
-
-multilib_src_install() {
- cmake_src_install
-
- if use doc && multilib_is_native_abi; then
- local HTML_DOCS=( "${S}/doxygen/html/." )
- fi
- einstalldocs
-}