summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/igraph/igraph-0.7.1-r2.ebuild')
-rw-r--r--dev-libs/igraph/igraph-0.7.1-r2.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-libs/igraph/igraph-0.7.1-r2.ebuild b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
index 83c2185d5b3e..b920276602c3 100644
--- a/dev-libs/igraph/igraph-0.7.1-r2.ebuild
+++ b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs
@@ -22,8 +22,8 @@ RDEPEND="
>=sci-libs/cxsparse-3
sci-mathematics/glpk
gmp? ( dev-libs/gmp:0 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
@@ -37,6 +37,7 @@ src_configure() {
econf \
$(use_enable gmp) \
$(use_enable debug) \
+ --disable-static \
--disable-tls \
--with-external-arpack \
--with-external-blas \
@@ -44,3 +45,10 @@ src_configure() {
--with-external-f2c \
--with-external-glpk
}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}