summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-23.17.26241.24.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 02a330817963..555223e44a94 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1 @@
-DIST intel-compute-runtime-23.17.26241.24.tar.gz 6562120 BLAKE2B a75299259f1a41daeff14b75b87140953baa79e75390f48ce64d614b0837341505c331178aa86e59e4bd678fb4409f51ca494d14b6d112b4b9219506ad5c75b3 SHA512 e82798cf4c0e8511bb64f6e5543e7b49232cc9c1027ec374ec5c2cbfac8848263a5cc72072fadfe1e19920f5bdf65ceaed465ea88d4b2baec3acac433d383978
DIST intel-compute-runtime-23.22.26516.18.tar.gz 6695812 BLAKE2B c413d0ee70564292122d3eb125669ffc0a0dd7491ec208688055a71173b4112db6da96934cd16c91c4ff1a932cf8fdea490c5d849d98c7171bc916d6d77dc837 SHA512 5949866da0c3e48582636b9260e9ee6321c06db543a30e8567310add1b93a7b37ee3e4f35dcd5d9a6f611ed701daa52fac98ae2c11e26809f3fe7da84d289fc3
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.17.26241.24.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-23.17.26241.24.ebuild
deleted file mode 100644
index 893db4b58b43..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.17.26241.24.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.3.5:="
-
-DEPEND="
- ${DEPEND}
- dev-libs/intel-metrics-discovery:=
- dev-libs/intel-metrics-library:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.13860.4
- >=dev-util/intel-graphics-system-controller-0.8.7:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.11.0:= )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- media-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=(
- "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
-)
-
-src_prepare() {
- # Remove '-Werror' from default
- sed -e '/Werror/d' -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-lto
-
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}