summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/isa-l/isa-l-2.30.0-r1.ebuild')
-rw-r--r--dev-libs/isa-l/isa-l-2.30.0-r1.ebuild35
1 files changed, 24 insertions, 11 deletions
diff --git a/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild b/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild
index 793f5856db3f..e80e64915e67 100644
--- a/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild
+++ b/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,28 +11,41 @@ SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~riscv"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv -x86"
IUSE="cpu_flags_x86_avx512f"
# AVX512 support in yasm is still work in progress
-BDEPEND="amd64? (
- cpu_flags_x86_avx512f? ( >=dev-lang/nasm-2.13 )
- !cpu_flags_x86_avx512f? ( || (
- >=dev-lang/nasm-2.11.01
- >=dev-lang/yasm-1.2.0
- ) )
-)"
+BDEPEND="
+ amd64? (
+ cpu_flags_x86_avx512f? ( >=dev-lang/nasm-2.13 )
+ !cpu_flags_x86_avx512f? ( || (
+ >=dev-lang/nasm-2.11.01
+ >=dev-lang/yasm-1.2.0
+ ) )
+ )
+ x86? (
+ cpu_flags_x86_avx512f? ( >=dev-lang/nasm-2.13 )
+ !cpu_flags_x86_avx512f? ( || (
+ >=dev-lang/nasm-2.11.01
+ >=dev-lang/yasm-1.2.0
+ ) )
+ )
+"
PATCHES=(
+ "${FILESDIR}"/${PN}-2.30.0_fix-shebang.patch
"${FILESDIR}"/${PN}-2.30.0_makefile-no-D.patch
+ "${FILESDIR}"/${PN}-2.30.0_makefile-x86.patch
)
src_prepare() {
default
- # isa-l does not support arbitrary assemblers on amd64 (and presumably x86),
+ # isa-l does not support arbitrary assemblers on amd64 and x86,
# it must be either nasm or yasm.
- use amd64 && unset AS
+ if use amd64 || use x86; then
+ unset AS
+ fi
eautoreconf
}