summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/json-glib')
-rw-r--r--dev-libs/json-glib/Manifest3
-rw-r--r--dev-libs/json-glib/json-glib-1.4.4.ebuild57
-rw-r--r--dev-libs/json-glib/json-glib-1.6.0.ebuild58
-rw-r--r--dev-libs/json-glib/json-glib-1.8.0.ebuild65
-rw-r--r--dev-libs/json-glib/metadata.xml40
5 files changed, 95 insertions, 128 deletions
diff --git a/dev-libs/json-glib/Manifest b/dev-libs/json-glib/Manifest
index 7af3068001ac..d0d6ff42a81d 100644
--- a/dev-libs/json-glib/Manifest
+++ b/dev-libs/json-glib/Manifest
@@ -1,2 +1 @@
-DIST json-glib-1.4.4.tar.xz 165584 BLAKE2B 0cdb518cd139b8dbdbf31c9bc00ddedca6385d7132843455a7898f3544fb43b62d6626d49944e83ef10ab9a555cf21c7e4548df7d784bcb4020f4026e0f3045e SHA512 cf56a99dce3938b5c0075810f105719836fac65392da33a49b26ebf33aee1fab89ca9fac58059a2008d688ecc75a3e524de60621a5b027d566963541f38b971f
-DIST json-glib-1.6.0.tar.xz 168648 BLAKE2B 45a323b49cb7e9b3b37fdceb0bd95585663983acee82fa8a54afb2c817e9b86332dd94775db0be81e7ff25cfd56515816487275165889f44fef918250b71115b SHA512 0025f913c54a223e6c5f7e65c081afc8ea65ab5a30ed9f30d2d2bb28d17c5695f6e308c64dfdf128e47ddc99d3178421204b5273e78305a096c0b7dfe67dd406
+DIST json-glib-1.8.0.tar.xz 157300 BLAKE2B eef0344c353bb9288efb700a6041342379627b924a042263e011f21140166b57b108f6816e80ac692159b49943f9c1afeb722efafa34e8c60f2fcdf53a0dc034 SHA512 e4fe16bb7c5b72fcf9c0966ac1903ff0cd74ec8eab891db4b94e92353bdcb57b24613b6c2cce7bfa1996603c367d1b4939c12209369dfb915aac0f3804a3a900
diff --git a/dev-libs/json-glib/json-glib-1.4.4.ebuild b/dev-libs/json-glib/json-glib-1.4.4.ebuild
deleted file mode 100644
index 0f1020925a1d..000000000000
--- a/dev-libs/json-glib/json-glib-1.4.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome.org meson multilib-minimal xdg-utils
-
-DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
-HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="gtk-doc +introspection"
-
-RDEPEND="
- >=dev-libs/glib-2.44.0:2[${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
-"
-# TODO: Can we use a newer docbook-xml-dtd, or is one needed at all?
-DEPEND="${RDEPEND}
- ~app-text/docbook-xml-dtd-4.1.2
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- dev-util/glib-utils
- gtk-doc? ( >=dev-util/gtk-doc-1.20 )
- >=sys-devel/gettext-0.18
- virtual/pkgconfig
-"
-
-src_prepare() {
- xdg_environment_reset
- default
- # Disable installed-tests; this also indirectly removes build_aux/gen-installed-test.py calls, thus not needing python-any-r1.eclass
- sed -e 's/install: true/install: false/g' -i json-glib/tests/meson.build || die
- sed -e '/install_data/d' -i json-glib/tests/meson.build || die
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Dintrospection=$(multilib_native_usex introspection true false)
- -Ddocs=$(multilib_native_usex gtk-doc true false)
- -Dman=true
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-multilib_src_test() {
- meson_src_test
-}
diff --git a/dev-libs/json-glib/json-glib-1.6.0.ebuild b/dev-libs/json-glib/json-glib-1.6.0.ebuild
deleted file mode 100644
index 35c0e160931a..000000000000
--- a/dev-libs/json-glib/json-glib-1.6.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit gnome.org meson multilib-minimal xdg-utils
-
-DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
-HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="gtk-doc +introspection"
-
-RDEPEND="
- >=dev-libs/glib-2.54.0:2[${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
-"
-DEPEND="${RDEPEND}"
-# TODO: Can we use a newer docbook-xml-dtd, or is one needed at all?
-BDEPEND="
- ~app-text/docbook-xml-dtd-4.1.2
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- dev-util/glib-utils
- gtk-doc? ( >=dev-util/gtk-doc-1.20 )
- >=sys-devel/gettext-0.18
- virtual/pkgconfig
-"
-
-src_prepare() {
- xdg_environment_reset
- default
- # Disable installed-tests; this also indirectly removes build_aux/gen-installed-test.py calls, thus not needing python-any-r1.eclass
- sed -e 's/install: true/install: false/g' -i json-glib/tests/meson.build || die
- sed -e '/install_data/d' -i json-glib/tests/meson.build || die
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Dintrospection=$(multilib_native_usex introspection enabled disabled)
- -Dgtk_doc=$(multilib_native_usex gtk-doc enabled disabled)
- -Dman=true
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-}
-
-multilib_src_test() {
- meson_src_test
-}
diff --git a/dev-libs/json-glib/json-glib-1.8.0.ebuild b/dev-libs/json-glib/json-glib-1.8.0.ebuild
new file mode 100644
index 000000000000..b08e122f0bc6
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-1.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
+HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="gtk-doc +introspection nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.54.0:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}"
+# TODO: Can we use a newer docbook-xml-dtd, or is one needed at all?
+BDEPEND="
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_environment_reset
+ default
+
+ # Disable installed-tests; this also indirectly removes
+ # build_aux/gen-installed-test.py calls, thus not needing
+ # python-any-r1.eclass
+ sed -e 's/install: true/install: false/g' -i json-glib/tests/meson.build || die
+ sed -e '/install_data/d' -i json-glib/tests/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature gtk-doc gtk_doc)
+ $(meson_native_true man)
+
+ $(meson_feature nls)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ if use gtk-doc ; then
+ # Move to location that <devhelp-41 will see, reconsider once devhelp-41 is stable
+ mkdir -p "${ED}"/usr/share/gtk-doc/html || die
+ mv "${ED}"/usr/share/doc/json-glib-1.0 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}
diff --git a/dev-libs/json-glib/metadata.xml b/dev-libs/json-glib/metadata.xml
index 0aa1782a946f..489464083a6c 100644
--- a/dev-libs/json-glib/metadata.xml
+++ b/dev-libs/json-glib/metadata.xml
@@ -1,15 +1,33 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>voyageur@gentoo.org</email>
- <name>Bernard Cafarelli</name>
- </maintainer>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <longdescription>JSON-GLib is a library providing serialization and deserialization support for the JavaScript Object Notation (JSON) format described by RFC 4627. Many high-level languages already provide native modules for parsing, generating and manipulating JSON data streams. JSON-GLib is a C library based on GLib and released under the terms of the GNU Lesser General Public License version 2.1. It provides a parser and a generator GObject classes and various wrappers for the complex data types employed by JSON, such as arrays and objects.
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription>
+ JSON-GLib is a library providing serialization and deserialization support
+ for the JavaScript Object Notation (JSON) format described by RFC 4627. Many
+ high-level languages already provide native modules for parsing, generating
+ and manipulating JSON data streams. JSON-GLib is a C library based on GLib
+ and released under the terms of the GNU Lesser General Public License
+ version 2.1. It provides a parser and a generator GObject classes and
+ various wrappers for the complex data types employed by JSON, such as arrays
+ and objects.
-JSON-GLib uses GLib native data types and the generic value container GValue for ease of development. It also provides integration with the GObject classes for direct serialization into, and deserialization from, JSON data streams.</longdescription>
+ JSON-GLib uses GLib native data types and the generic value container GValue
+ for ease of development. It also provides integration with the GObject
+ classes for direct serialization into, and deserialization from, JSON data
+ streams.
+ </longdescription>
+ <use>
+ <flag name="nls">Enable native language support (translations)</flag>
+ </use>
+ <upstream>
+ <remote-id type="gnome-gitlab">GNOME/json-glib</remote-id>
+ </upstream>
</pkgmetadata>