summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jthread/jthread-1.3.1.ebuild')
-rw-r--r--dev-libs/jthread/jthread-1.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/jthread/jthread-1.3.1.ebuild b/dev-libs/jthread/jthread-1.3.1.ebuild
new file mode 100644
index 000000000000..6eb50cde0722
--- /dev/null
+++ b/dev-libs/jthread/jthread-1.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
+HOMEPAGE="http://research.edm.uhasselt.be/~jori/page/index.php?n=CS.Jthread"
+SRC_URI="http://research.edm.uhasselt.be/jori/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DOCS=( ChangeLog README.TXT TODO doc/manual.tex )
+
+src_prepare() {
+ # do not build static library, if it is not requested
+ if ! use static-libs; then
+ sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
+ fi
+}