summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbytesize')
-rw-r--r--dev-libs/libbytesize/Manifest1
-rw-r--r--dev-libs/libbytesize/libbytesize-2.8.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index b43d83f524a8..3458e34920ce 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1,3 +1,2 @@
DIST libbytesize-2.10.tar.gz 458804 BLAKE2B 413a45bebf8394e0557c2e1ef7e1f4348fa6dfa52c697599886d70292ea8b2e1b17402e787afaeb8fecd84e3a37a6c0c39440fa22a556dcaba3f419ee17e1b0e SHA512 9e52b9a756a5b4ee6e23a7a20fd0c6ca2a65ff31f38ddc7545d6838fe9a3da0ee0bd7491cb268f071c950fbeb8d65c707423d285cc3548038b3a2d3aa7f0de48
-DIST libbytesize-2.8.tar.gz 458581 BLAKE2B 55726f5a83ecda96be58bd5fe650555b0ebd210d73673b7ced6476689c7d37a5d9107f917ac8b0b15b4e2e8cee0a0da8711e718baa07de166979f44287432a14 SHA512 96543b75dd5a3409e0316b46725409bc5b04acb0d6c85875bbc2eb8cfd842c543ace99ffe84c09c16daa3fd1346d2aa64df20ed171bb4540642fdba7499922ca
DIST libbytesize-2.9.tar.gz 458737 BLAKE2B d2e47b520cf2669131816f069d8ebeb946be02bc04acc676579f12e798fcb2aa176fd25e6bb77dd1e6b274ec0762498df5df18d88c627653accc426a7e268f36 SHA512 6def6bebe33344e6d6ce1a636bcd200a9d28ed5c4e5ce5dfbfd94c4d92ba37512ef1ee4f12716af0d6a402d5285e60df1ee629ecf31cf7d0b59990c524384fd1
diff --git a/dev-libs/libbytesize/libbytesize-2.8.ebuild b/dev-libs/libbytesize/libbytesize-2.8.ebuild
deleted file mode 100644
index 79987e5858ee..000000000000
--- a/dev-libs/libbytesize/libbytesize-2.8.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit autotools python-r1
-
-DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
-HOMEPAGE="https://github.com/storaged-project/libbytesize"
-SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="doc python test tools"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- tools? ( python )
-"
-
-RDEPEND="
- dev-libs/gmp:0=
- dev-libs/mpfr:=
- dev-libs/libpcre2:=
- python? ( ${PYTHON_DEPS} )
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- sys-devel/gettext
- doc? (
- dev-util/gtk-doc
- virtual/pkgconfig
- )
- test? (
- dev-python/pocketlint[${PYTHON_USEDEP}]
- dev-python/polib[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( README.md )
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4-no_Werror.patch"
-)
-
-python_do() {
- if use python ; then
- python_foreach_impl run_in_build_dir "$@"
- else
- "$@"
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with doc gtk-doc)
- $(use_with python python3)
- $(use_with tools)
- )
- local ECONF_SOURCE="${S}"
- python_do econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- python_do emake
-}
-
-src_test() {
- python_do emake check
-}
-
-install_helper() {
- emake DESTDIR="${D}" install
- use python && python_optimize
-}
-
-src_install() {
- python_do install_helper
- einstalldocs
- find "${ED}" -name "*.la" -type f -delete || die
-}