summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcbor/libcbor-0.10.2.ebuild')
-rw-r--r--dev-libs/libcbor/libcbor-0.10.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-libs/libcbor/libcbor-0.10.2.ebuild b/dev-libs/libcbor/libcbor-0.10.2.ebuild
index db0bd0476f03..83c83a5ed6ba 100644
--- a/dev-libs/libcbor/libcbor-0.10.2.ebuild
+++ b/dev-libs/libcbor/libcbor-0.10.2.ebuild
@@ -12,14 +12,14 @@ SRC_URI="https://github.com/PJK/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="+custom-alloc doc test"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="doc test"
BDEPEND="
doc? (
$(python_gen_any_dep '
dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
dev-python/breathe[${PYTHON_USEDEP}]
')
)
@@ -31,7 +31,7 @@ RESTRICT="!test? ( test )"
python_check_deps() {
python_has_version \
"dev-python/sphinx[${PYTHON_USEDEP}]" \
- "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]" \
+ "dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]" \
"dev-python/breathe[${PYTHON_USEDEP}]"
}
@@ -42,7 +42,6 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
-DCMAKE_BUILD_TYPE=Release
- -DCBOR_CUSTOM_ALLOC=$(usex custom-alloc 'ON' 'OFF')
-DWITH_TESTS=$(usex test 'ON' 'OFF')
)
@@ -55,7 +54,7 @@ src_compile() {
if use doc; then
mkdir -p doc/build || die
pushd doc >/dev/null || die
- emake html man
+ emake -j1 html man
popd >/dev/null || die
fi
}