summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libconfig/libconfig-1.7.3.ebuild')
-rw-r--r--dev-libs/libconfig/libconfig-1.7.3.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-libs/libconfig/libconfig-1.7.3.ebuild b/dev-libs/libconfig/libconfig-1.7.3.ebuild
index 5e436a5f4869..449f75c98860 100644
--- a/dev-libs/libconfig/libconfig-1.7.3.ebuild
+++ b/dev-libs/libconfig/libconfig-1.7.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,20 +7,21 @@ inherit autotools multilib-minimal
DESCRIPTION="Libconfig is a simple library for manipulating structured configuration files"
HOMEPAGE="
- http://www.hyperrealm.com/libconfig/libconfig.html
+ https://www.hyperrealm.com/libconfig/libconfig.html
https://github.com/hyperrealm/libconfig
"
SRC_URI="https://github.com/hyperrealm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/11"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
-IUSE="+cxx static-libs"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
+IUSE="+cxx static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
sys-apps/texinfo
- sys-devel/bison
- sys-devel/libtool
+ app-alternatives/yacc
+ dev-build/libtool
"
src_prepare() {
@@ -33,10 +34,14 @@ src_prepare() {
}
multilib_src_configure() {
- econf \
- $(use_enable cxx) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_enable cxx)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
--disable-examples
+ )
+
+ econf "${myeconfargs[@]}"
}
multilib_src_test() {