summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcpuid/libcpuid-0.6.2.ebuild')
-rw-r--r--dev-libs/libcpuid/libcpuid-0.6.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-libs/libcpuid/libcpuid-0.6.2.ebuild b/dev-libs/libcpuid/libcpuid-0.6.2.ebuild
deleted file mode 100644
index c3576366dccf..000000000000
--- a/dev-libs/libcpuid/libcpuid-0.6.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=(python3_{9..11})
-
-inherit autotools python-any-r1
-
-DESCRIPTION="A small C library for x86 (and x86_64) CPU detection and feature extraction"
-HOMEPAGE="http://libcpuid.sourceforge.net/"
-SRC_URI="https://github.com/anrieff/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-2"
-SLOT="0/16"
-KEYWORDS="~amd64"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf "$(use_enable static-libs static)"
-}
-
-src_install() {
- default
- find "${ED}" -name "*.la" -delete || die
-}