summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcxml/libcxml-0.15.4.ebuild')
-rw-r--r--dev-libs/libcxml/libcxml-0.15.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libcxml/libcxml-0.15.4.ebuild b/dev-libs/libcxml/libcxml-0.15.4.ebuild
new file mode 100644
index 000000000000..e026d6e56307
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-0.15.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="small C++ library which makes it marginally neater to parse XML using libxml++"
+HOMEPAGE="http://carlh.net/libcxml"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-cpp/libxmlpp:2.6
+ dev-libs/boost"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.1-respect-cxxflags.patch )