summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdivecomputer/libdivecomputer-9999.ebuild')
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-9999.ebuild59
1 files changed, 15 insertions, 44 deletions
diff --git a/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
index 05e2cc29858a..9f8a7f678342 100644
--- a/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
+++ b/dev-libs/libdivecomputer/libdivecomputer-9999.ebuild
@@ -1,62 +1,33 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="git://git.libdivecomputer.org/libdivecomputer.git"
- GIT_ECLASS="git-2"
- AUTOTOOLS_AUTORECONF=1
- KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/libdivecomputer/libdivecomputer"
+ inherit autotools git-r3
else
+ SRC_URI="https://www.libdivecomputer.org/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-AUTOTOOLS_IN_SOURCE_BUILD=1
-inherit eutils autotools-utils ${GIT_ECLASS}
-
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
- SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
-fi
-
-DESCRIPTION="Library for communication with dive computers from various manufacturers"
-HOMEPAGE="http://www.divesoftware.org/libdc"
+DESCRIPTION="Library for communication with dive computers from various manufacturers."
+HOMEPAGE="https://www.libdivecomputer.org"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="usb +static-libs -tools"
+IUSE="bluetooth"
-RDEPEND="usb? ( virtual/libusb:1 )"
+RDEPEND="virtual/libusb:1
+ bluetooth? ( net-wireless/bluez )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_configure() {
- autotools-utils_src_configure
-
- if ! use tools ; then
- sed -i 's|examples||' Makefile || die "sed failed"
- fi
+src_prepare() {
+ default
+ [[ -v EGIT_REPO_URI ]] && eautoreconf
}
-src_install() {
- autotools-utils_src_install
-
- if use tools ; then
- einfo "prefixing tools with 'dctool_'"
- pushd "${D}/usr/bin/"
- for file in * ; do
- mv "${file}" "dctool_${file}" || die "prefixing tools failed"
- done
- popd
- fi
-}
-
-pkg_postinst() {
- if use tools ; then
- elog "The 'tools' USE flag has been enabled,"
- elog "to avoid file collisions, all ${PN}"
- elog "related tools have been prefixed with 'dctool_'"
- fi
+src_configure() {
+ econf $(use_with bluetooth bluez)
}