summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libee/libee-0.3.2-r2.ebuild')
-rw-r--r--dev-libs/libee/libee-0.3.2-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libee/libee-0.3.2-r2.ebuild b/dev-libs/libee/libee-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..ee64fc50d042
--- /dev/null
+++ b/dev-libs/libee/libee-0.3.2-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="An Event Expression Library inspired by CEE"
+HOMEPAGE="http://www.libee.org"
+SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2
+ dev-libs/libestr"
+RDEPEND="${DEPEND}"
+
+DOCS=(INSTALL ChangeLog)
+PATCHES=("${FILESDIR}"/0.3.2-add_math_lib_configure.patch
+"${FILESDIR}"/0.3.2-add_math_lib_pc_in.patch)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ --enable-testbench
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile -j1
+}