summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libg15/libg15-3.0.7.ebuild')
-rw-r--r--dev-libs/libg15/libg15-3.0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libg15/libg15-3.0.7.ebuild b/dev-libs/libg15/libg15-3.0.7.ebuild
new file mode 100644
index 000000000000..0a74e03e1c6a
--- /dev/null
+++ b/dev-libs/libg15/libg15-3.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://gitlab.com/menelkir/libg15.git"
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+ SRC_URI="https://gitlab.com/menelkir/${PN}/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
+HOMEPAGE="https://gitlab.com/menelkir/libg15"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -type f -name '*.la' -delete || die
+}