summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgpg-error/libgpg-error-1.26.ebuild')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.26.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.26.ebuild b/dev-libs/libgpg-error/libgpg-error-1.26.ebuild
index dc55017d36f1..4826afb211c4 100644
--- a/dev-libs/libgpg-error/libgpg-error-1.26.ebuild
+++ b/dev-libs/libgpg-error/libgpg-error-1.26.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils libtool multilib-minimal toolchain-funcs
@@ -31,30 +31,21 @@ MULTILIB_WRAPPED_HEADERS=(
)
src_prepare() {
- epatch_user
+ default
elibtoolize
}
multilib_src_configure() {
- local myeconfargs=(
- CC_FOR_BUILD=$(tc-getBUILD_CC)
- --enable-threads
- $(use_enable nls)
- $(use_enable static-libs static)
- $(use_enable common-lisp languages)
- )
-
- multilib_is_native_abi || myeconfargs+=(
- --disable-languages
- )
-
- ECONF_SOURCE=${S} \
- econf "${myeconfargs[@]}"
+ ECONF_SOURCE="${S}" econf \
+ CC_FOR_BUILD=$(tc-getBUILD_CC) \
+ --enable-threads \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable common-lisp languages) \
+ $(multilib_is_native_abi || echo --disable-languages)
}
multilib_src_install_all() {
einstalldocs
-
- # library has no dependencies, so it does not need the .la file
prune_libtool_files --all
}