summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libite/libite-2.5.1.ebuild')
-rw-r--r--dev-libs/libite/libite-2.5.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/libite/libite-2.5.1.ebuild b/dev-libs/libite/libite-2.5.1.ebuild
new file mode 100644
index 000000000000..2caf2e8389ae
--- /dev/null
+++ b/dev-libs/libite/libite-2.5.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libite"
+SRC_URI="https://github.com/troglobit/libite/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ econf --enable-static=no
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}