summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/libixion-0.17.0.ebuild4
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/dev-libs/libixion/libixion-0.17.0.ebuild b/dev-libs/libixion/libixion-0.17.0.ebuild
index 69eac26d6118..69c4d1bf9dfd 100644
--- a/dev-libs/libixion/libixion-0.17.0.ebuild
+++ b/dev-libs/libixion/libixion-0.17.0.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="MIT"
SLOT="0/0.17" # based on SONAME of libixion.so
-IUSE="debug python +threads"
+IUSE="debug python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -43,12 +43,10 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --disable-static
$(use_enable debug)
$(use_enable debug debug-utils)
$(use_enable debug log-debug)
$(use_enable python)
- $(use_enable threads)
)
econf "${myeconfargs[@]}"
}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 982b9e013cdb..5d1e81d42e19 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="MIT"
SLOT="0/0.18" # based on SONAME of libixion.so
-IUSE="debug python +threads"
+IUSE="debug python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -44,12 +44,10 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --disable-static
$(use_enable debug)
$(use_enable debug debug-utils)
$(use_enable debug log-debug)
$(use_enable python)
- $(use_enable threads)
)
econf "${myeconfargs[@]}"
}