summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liblognorm/files')
-rw-r--r--dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch41
-rw-r--r--dev-libs/liblognorm/files/respect_CFLAGS.patch11
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch b/dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch
new file mode 100644
index 000000000000..3bffe5ec74f0
--- /dev/null
+++ b/dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch
@@ -0,0 +1,41 @@
+[PATCH] Turn --disable-docs into --enable-docs and make it work
+
+See upstream issue #16 for more details.
+---
+ configure.ac | 22 ++++++++++++++--------
+ 1 file changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 547908c..26a2f96 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -96,15 +96,21 @@ fi
+
+ # docs (html) build settings
+ AC_ARG_ENABLE(docs,
+- [AS_HELP_STRING([--disable-docs],[Disable building HTML docs (requires Sphinx)])],
+- [enable_docs="no"],
+- [enable_docs="yes"]
++ [AS_HELP_STRING([--enable-docs],[Enable building HTML docs (requires Sphinx) @<:@default=no@:>@])],
++ [case "${enableval}" in
++ yes) enable_docs="yes" ;;
++ no) enable_docs="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-docs) ;;
++ esac],
++ [enable_docs="no"]
+ )
+-AC_CHECK_PROGS([SPHINXBUILD], [sphinx-build sphinx-build3 sphinx-build2], [no])
+-AS_IF([test "$enable_docs" = "yes" -a "x$SPHINXBUILD" = xno],
+- [AC_MSG_ERROR([sphinx-build is required to build documentation, install it or try --disable-docs])]
+-)
+-AM_CONDITIONAL([ENABLE_DOCS], [test "$enable_docs" = yes])
++if test "$enable_docs" = "yes"; then
++ AC_CHECK_PROGS([SPHINXBUILD], [sphinx-build sphinx-build3 sphinx-build2], [no])
++ if test "$SPHINXBUILD" = "no"; then
++ AC_MSG_ERROR([sphinx-build is required to build documentation, install it or try --disable-docs])
++ fi
++fi
++AM_CONDITIONAL([ENABLE_DOCS], [test "$enable_docs" = "yes"])
+
+ AC_ARG_ENABLE(testbench,
+ [AS_HELP_STRING([--enable-testbench],[testbench enabled @<:@default=no@:>@])],
diff --git a/dev-libs/liblognorm/files/respect_CFLAGS.patch b/dev-libs/liblognorm/files/respect_CFLAGS.patch
new file mode 100644
index 000000000000..6e8d28099ee9
--- /dev/null
+++ b/dev-libs/liblognorm/files/respect_CFLAGS.patch
@@ -0,0 +1,11 @@
+--- configure.ac.new 2014-03-20 10:56:14.777901140 +0200
++++ configure.ac 2014-03-20 10:56:50.154143106 +0200
+@@ -12,7 +12,7 @@
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+ if test "$GCC" = "yes"
+-then CFLAGS="$CFLAGS -W -Wall -Wformat-security -Wshadow -Wcast-align -Wpointer-arith -Wmissing-format-attribute -g"
++then CFLAGS="$CFLAGS -W -Wall -Wformat-security -Wshadow -Wcast-align -Wpointer-arith -Wmissing-format-attribute"
+ fi
+
+ AC_PROG_LIBTOOL