summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild
index 040220a1d88a..592c4a66ef6e 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Provides an uniform interface to access several encryption algorithms"
HOMEPAGE="https://mcrypt.sourceforge.net"
@@ -36,6 +36,14 @@ src_prepare() {
eautoreconf # update stale autotools
}
+src_configure() {
+ # LTO type mismatch (bug #924867)
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die