summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libowfat/libowfat-0.31-r1.ebuild')
-rw-r--r--dev-libs/libowfat/libowfat-0.31-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-libs/libowfat/libowfat-0.31-r1.ebuild b/dev-libs/libowfat/libowfat-0.31-r1.ebuild
deleted file mode 100644
index 409b88fc630f..000000000000
--- a/dev-libs/libowfat/libowfat-0.31-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein"
-SRC_URI="https://www.fefe.de/${PN}/${P}.tar.xz"
-HOMEPAGE="https://www.fefe.de/libowfat/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa sparc x86"
-IUSE="diet"
-
-RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-pkg_setup() {
- # Required for mult/umult64.c to be usable
- append-flags -fomit-frame-pointer
-}
-
-src_compile() {
- emake \
- CC=$(tc-getCC) \
- CFLAGS="-I. ${CFLAGS}" \
- DIET="/usr/bin/diet -Os" \
- prefix=/usr \
- INCLUDEDIR=/usr/include/libowfat \
- $( use diet || echo 'DIET=' )
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- LIBDIR="/usr/$(get_libdir)" \
- MAN3DIR="/usr/share/man/man3" \
- INCLUDEDIR="/usr/include/libowfat" \
- install
-
- cd "${D}"/usr/share/man
- mv man3/buffer.3 man3/owfat-buffer.3
-}